Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Login



  • I have no idea how to login to Surfer. It is strange that it does not come with a default login. There are not files to be adjusted where I could enter a login either. Does anyone know how to create a user and login for Surfer?


  • Staff

    @Shaun-Snapp You just use the Cloudron username and password.

    I think you asked a similar question about meemo as well. Many of the apps on Cloudron are integrated with Cloudron Directory. You can select at installation time whether you want to authenticate against the Cloudron Directory or not.

    With Cloudron User Management integration, if you add user on Cloudron dashboard, they can login to apps using the same username and password. You can control who has access to which app in the Access Control section of each app.



  • Girish,

    Seems like a great feature. However, I tried logging in with my username and passwords from Cloudron into several of my apps, but none of them accepted the usernames and passwords I created. I saw the selection you are referring to when I brought up each new app, that is to make it compatible with Cloudron users. I had been doing this previously (accepting the default), but did not know what it meant.

    I wonder what I am doing wrong.


  • Staff

    @Shaun-Snapp So, you see this behavior with all apps? That you cannot login to meemo/surfer with your Cloudron credentials? Just to be 100% sure, can you open the Cloudron dashboard in anonymous mode and login with your credentials to see if the credentials are correct or maybe auto fill is doing something strange. Thanks.



  • @girish

    I became confused as I was not getting emails for the new accounts I was creating and mistaken the restatement of the username as a password I had set. (I created the users one day, and then tried to use them to login several days later when you told me I could do this).

    My error. But I am now into several apps. This is great. I don't even have to worry about setting the password in apps. Fantastic. I need to next look into why it is not creating new emails after I create a user. I checked the spam folder as well. Thanks for your help.


  • Staff

    @Shaun-Snapp In the email view, there is an activity log. It should tell you hopefully what's happening to those invite mails. If you are on a fresh server, it's common that IP is blacklisted and mail servers will reject your mail. You can get a rough idea with Mail -> Select Domain -> Status.



  • @girish

    The log says that it delivered mail, but I don't see it in Gmail. But I tried my other email service and it worked.

    I am still having a problem with Jupyter Notebook. That is rejecting the same password that is working in all the other apps.


  • Staff

    @Shaun-Snapp I quickly checked JupyterHub and the app does work fine (in fact, it's deployed in a couple of universities, so I would be surprised if it breaks). Do you see anything in the logs when you login ? Console -> Logs.



  • @girish

    Yes, I was using a capital in the username. Now I have access after creating a new user with no caps. Thanks.


Log in to reply