SuiteCRM


  • Cloudron.io team

    Would be useful to my shop and I expect many others.https://suitecrm.com/


  • Cloudron.io team

    This was posted by some on chat yesterday (https://paste.cloudron.io/raw/upesuzizis)

    • install an empty LAMP stack
    • download and extract SuiteCRM fromhttps://suitecrm.com/download/ (upload either via sftp or wget and unzip in terminal) in /app/data/public
    • depending on how you got the files there, you need to do a "chown -R www-data:www-data /app/data/public" so it is able to write the config files
    • get environment variables in terminal with env | grep MYSQL_ and install SuiteCRM as you usually would
    • login with the newly created admin account and go to Admin -> Password Management, select" Enable LDAP Authentication" and enter at least the following information:
      • Server: 172.18.0.1
      • Port: 3002
      • User DN: ou=users,dc=cloudron
      • Bind Attribute: dn
      • Login-Attribute: username
    • give it a try if it's working, if it does, do a vi /app/data/public/config.php and replace the static db infos with the environment variables like so:
      array (
      'db_host_name' => getenv("MYSQL_HOST"),
      'db_host_instance' => 'SQLEXPRESS',
      'db_user_name' => getenv("MYSQL_USERNAME"),
      'db_password' => getenv("MYSQL_PASSWORD"),
      'db_name' => getenv("MYSQL_DATABASE"),
      'db_type' => 'mysql',
      'db_port' => getenv("MYSQL_PORT"),
      'db_manager' => 'MysqliManager',
      ),
    • save and see if everything is still working

  • Cloudron.io team

    (Matthias also said) Ah yes, that was me. Additional note: If you migrate an existing installation, make sure to enable LDAP login on every user (in advanced settings) and of course check "Auto Create Users" in password settings, that should get you going.


  • Cloudron.io team

    http://www.jsmackin.co.uk/suitecrm/suitecrm-command-line-install/ has some interesting information on automated installs


 

Looks like your connection to Cloudron Forum was lost, please wait while we try to reconnect.