Webadmin error on manual update of self-hosting free-plan



  • Hi everyone!

    I've got a huge issue on manually updating my free-plan self-hosting cloudron from 1.11.0 to 2.0.0. I use the documented methode on the git, and I add the webadmin part : since v1.10 (as I recall), the box repo doesn't contain the webadmin part anymore, but search for the directory ../webadmin.
    On v2.0.*, in the start.sh script, at line 218, it tries to create a json in the /home/yellowtent/box/webadmin/dist/ directory, but it does not exists! A directory /home/yellowtent/box/dashboard/dist/ exists (it might be related to the webadmin repo renamed into dashboard, but depite my investigations on the code, I didn't find where it is created).
    The installation fails because of this error, and after that, I've got a 404 error on trying to access to the cloudron, and I can't connect with cloudron CLI.
    I tried to re-run the script after creating a webadmin/dist directory, but it gives me a 403 error (most certainly because I didn't passed the right parameters, thus many of my cloudron.conf fields are empty). I still have access to cloudron CLI and to all my apps. I just don't have the cloudron page anymore.

    Do any of you have an idea on how to fix this issue and correctly update to 2.0.1 ?
    Thanks!

    UPDATE :
    I browsed the code of both box and webadmin for v2.0.0 : dashboard is never used, but webadmin is. So I copied the created config.json from webadmin/dist to dashboard/config.json, renamed dashboard into webadmin, and restarted box service. The interface came back (yay!) but it gives me an "Unknown OAuth client" error. It may be because of my config/cloudron.conf. Or do I have to restart another service.



  • The webadmin repo got renamed to dashboard. Please remove the webadmin folder (which should be on the same level as the box repo folder), and in-place clone https://git.cloudron.io/cloudron/dashboard then hotfixing your Cloudron should work again.



  • @nebulon Well, in the createReleaseTarball script, line 32, it searches for the webadmin directory. So I renamed my dashboard directory into webadmin.
    I hotfix my Cloudron, and it gives me the error :

    /home/yellowtent/box/setup/start.sh: line 218: /home/yellowtent/box/webadmin/dist/config.json: No such file or directory
    

    And now my Cloudron is down. I rename box/dashboard into box/webadmin, I copy the old webadmin/dist/config.json into it, then I call again box/setup/start.sh. But now my config/cloudron.conf is a bit empty, so I replace it by a backup. I restart with systemctl restart box, and at last, my Cloudron is up again. I can access to all my apps! But the cloudron page itself is no more available because of an Unknown OAuth client.
    So is the current state of my 2.0.1 Cloudron.



  • Oh I see, I was referring to both repo's master branches. So for that particular release, it was still webadmin indeed, so you have to make sure to checkout the correct release version tags for both of them. Having said that, we don't actively test hotfixing for releases, as the name indicates, it is intended as a developer tool.



  • @nebulon Well, if I understand correctly, either I update my cloudron to the master branch, or I wait for the next release that, I hope, will correct that issue. Is there another option, isn't it possible to fix it?



  • @carbonbee What I don't understand is why, during the build on the server with the hotfix methode, a dashboard directory is created, instead of a webadmin? Because almost everything seems to relies on this webadmin directory.



  • @carbonbee. I have 3 pro plans and i have 2 test servers with free plans for testing and i use hotfix cli method to update them. With few adjustments it works.

    1. on the cli machine clone box and dashboard with git
      For the dashboard i clone the code in webadmin directory : git clone https://git.cloudron.io/cloudron/dashboard.git webadmin
      In the webadmin directory and the box directory checkout the version you want

    2. Hotfix command

    3. On the cloudron machine you need to change version in cloudron.conf

    4. In the box directory, rename dashboard directory in webadmin

    5. go to box/webadmin/dist and create config.json within :
      {
      "webServerOrigin": "https://cloudron.io"
      }

    6. Reboot your server and cross your fingers.

    Everything works for me with this this non academic method.



  • Ok, thanks to a fellow cloudron user on the chat (many thanks robi !), I just made my admin page up again. I just copied my webadmin directory on my server to a dashboard directory on the same level, and yay! the OAuth error just disapeared!



  • @darkben Well, that's exactly what I did, but it ends with the OAuth error. I just fixed it (see my last answer :) ).



  • ok @CarbonBee i don't notice this Oauth error on my server but i keep an eye on this post.
    PS : i totally reboot the server and not only Cloudron...
    Thanks !



  • Did you guys figure this out? Sorry for the confusion with all those moving directories.



  • I have the same error "Unknown OAuth client" if I try to login at my.<domain>.<tld>. I tried the fix from darkben/CarbonBee without any luck.

    Btw. Where can I find the current documentation for manual updates since the wiki page on the box repo is gone.



  • I guess you are looking for https://git.cloudron.io/cloudron/box/wikis ?



  • @girish Yes thats where the wiki was accessible before. Currently I get "The page could not be found or you don't have permission to view it.".

    And any ideass concerning the OAuth Error?



  • @x1tan I have made the page publicly accessible now. For some reason it had a wrong setting there.