Cannot install locally build cloudron app



  • Hi,

    I've first encountered this a few months ago when trying some local modifications to the openvpn app, but filed it as "maybe this is related to this app". Now I wanted to update an app, which I in the past was able to build and install locally, but it gives the same error:

    07:59 $ which cloudron
    /usr/bin/cloudron
    ✔ ~/.../git/cloudron-webhook-app [master|✔]
    07:59 $ cloudron version
    1.6.0
    ✔ ~/.../git/cloudron-webhook-app [master|✔]
    07:59 $ cloudron build
    Building com.github.webhook@0.1.1
    
    Build scheduled with id eb6b02f2-0d2f-4310-b6b6-8a434487ba85
    Waiting for build to begin, this may take a bit...
    Building
    Step 1/8 : FROM cloudron/base:0.10.0
     ---> 5ec8ca8525be
    [....]
    Layer already exists 59f161c3069d
    eb6b02f2-0d2f-4310-b6b6-8a434487ba85: digest: sha256:534a6803b244001c4b235ca7a065720bacb6a7233e4c982806d1c8c945a71b21 size: 10378
    Build succeeded
    Success
    ✔ ~/.../git/cloudron-webhook-app [master|✔]
    07:59 $ cloudron install
    ERROR No image found, please run `cloudron build` first or specify a `dockerImage` in the CloudronManifest [ /usr/lib/node_modules/cloudron/src/helper.js:68:29 ]
    ✘-1 ~/.../git/cloudron-webhook-app [master|✔]
    07:59 $
    


  • Can you try to move or remove the cli config file, which stashes the build information? It is located at ~/.cloudron.json



  • Hi @nebulon ,

    thanks that did the trick. After moving ~/.cloudron.json to another location I can run cloudron install again.

    I have still a copy of the old file do you want to have a look into it?



  • @fbartels Yes, the format of cloudron.json had changed between the CLI version. We didn't write the migration code since we thought it wasn't important.