Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Gitea with Github OAuth throws error 500

  • When trying to sign in to Gitea by means of the Github OAuth authorization scheme, Gitea throws error 500. This is what logs in the back:

    Feb 06 13:59:53 2019/02/06 13:59:53 [...routers/user/auth.go:548 handleOAuth2SignIn()] [E] UserSignIn: Post dial tcp: lookup on read udp> i/o timeout

    Up until the last or last few updates, this has worked flawlessly. Is the error Gitea's or Github's?

  • Staff

    @yusf Can you check if unbound is running ? It's in system -> services.

  • It was not! After clicking its restart button the service came to life and Github OAuth works. Thanks! The box was freshly rebooted however, so how can I make sure unbound doesn't go down?

  • Staff

    @yusf This should be automatic but unbound goes down if the disk space is full. There is no workaround for this since this is a bug in the upstream project and will get fixed at some point.