mailserver uses old certs - with workaround



  • even so, that the box hast renewed the certs a month ago, the mailserver is still using the old, expired ones.
    Meanwhile the Server had been restarted a couple of times, as well as restarting the mail-container didn't help.

    cloudron version v3.5.4

    Workaround:
    copy the certs to the mailserver-volume and restart dovecot

    DOMAIN=<yourdomain.here>
    install -g yellowtent -o yellowtent -m 644 my.${DOMAIN}.cert /home/yellowtent/platformdata/addons/mail/tls_cert.pem
    docker exec mail supervisorctl restart dovecot
    


  • @chymian Thanks for the workaround! There was indeed a bug in the older versions (pre-3.5.4) that caused this problem. This is fixed in 3.5.4, so you don't have to repeat the workaround again for the next cert renewal.



  • Another option is to simply Disable mail and then Enable mail for the domain. This will effectively end up copying the certs.


Log in to reply