Kimai local.yaml



  • hi guys! first time posting

    i am having trouble with the kimai rounding options:

    https://www.kimai.org/documentation/timesheet.html#rounding-of-begin-end-and-duration

    technically, if i input 15 for beginn, end and duration, i should be able to round up my times as i need them (15 minute step). while searching for the location of the local.yaml file via SSH on my DO installation, i found it inside the "appsdata" folder for the kimai app, as if it were there specially for easy access. i made the changes but its not working and i am not sure what i am doing wrong, or if the file just doesnt get loaded at all and serves some other purpose.

    later, i also used the cloudron terminal for kimai and found the loca.yaml in the location the kimai docs said it would be, and it had updated the changes.

    again, i am not sure if my settings are wrong or if the file is not getting loaded. any help is appreciated!


    my settings, even though i know this is too kimai specific:

    kimai:
    timesheet:
    rounding:
    default:
    begin: 15
    end: 15
    duration: 15
    mode: default



  • Actually what you have explained is correct and should work. The /app/data/local.yaml is exactly there for this use-case. Have you restarted the app after applying the changes, in order to have the app assets rebuilt?



  • @squareclouds I noticed you said appsdata. Instead of editing files directly on the server, use the Web Terminal in the Debug view of the app. Then go to /app/data (only this data is persisted and part of a backup. all other data in a container is transient). After editing, you can then click on the Restart button at the top of the Terminal.



  • hi guys,

    yes, i actually restarted everything, app, couldron and then even the digitalocean droplet, but no changes 😕 i will try it tomorrow again and report back



  • hi all,

    i managed to make the changes, i had two mistakes:

    • i had to clear the kimai cache via terminal (it is in the kimai docs)
      https://www.kimai.org/documentation/configurations.html

    • when trying to clear, so the effects take place, i got an error. apparently you cannot use tabs as indentation, so my local.yaml was not readable anyway

    after using spaces and clearing successfully the cache, every worked 🙂

    thanks for the help!


Log in to reply