Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

Can we use Cloudron SMTP for Ghost email config

  • Hi, I’ve tried setting up the email settings (member signup, signin) in Ghost with Cloudron SMTP following this guide:

    In config.production.json, I tried:

    "mail": {
        "transport": "SMTP",
        "options": {
            "from": "",
            "host": "",
            "port": 443,
            "auth": {
                "user": “”
                "pass": "cloudronpass"
 my primary Cloudron domain , the Ghost app domain a mailbox I created for another app.

    I’ve tried port 25, 587, 993 & other combinations, but the subscribing is still not working.

    I go back to thinking is this possible? Do you guys have any ideas for this?

  • Staff

    @vjvanjungg Cloudron configure email automatically for Ghost (in fact, it does this for all apps). You shouldn't have to edit the json file manually. If you just restart the app, it will go back to the previous configuration.

    Can you clarify what is needed for the subscriptions to work? Ghost needs to be send emails as even though it's installed at ?

  • @girish

    If you just restart the app, it will go back to the previous configuration.

    yes, this is an issue i was getting when restarting the app.

    so for the sub to work, from what i’ve read on the forum, the email config should be set up properly (like the code block above).

    otherwise, it will show an error msg “Please enter a valid email address” when someone’s trying to subscribe.

    some folks use Mailgun or Amazon SES with their credentials. so i was wondering if Cloudron SMTP could work out for this.

    I’m mostly unsure of the port, the user & the from field input. It’s not absolutely needed to send email from, i was just testing out variants to see.

  • Staff

    @vjvanjungg Let me read up on what config is required and get back here.

  • Can you get back now, if possible?

    Same issue, we have to follow a different credential and restart Ghost for it to become live. But once I hit restart it reverts back to previous (default) config. It's trouble here.

  • Staff

    @iamdinakar Can you open a separate thread for the issue you are facing?