Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.



  • Hi all,

    I've been using a Scaleway storage to backup my instance on a 3-day basis but I've been getting various timeout errors since the last 5 days (each day):

    Message: write EPIPE HTTP Code: NetworkingError.
    
    Message: Your socket connection to the server was not read from or written to within the timeout period. HTTP Code: RequestTimeout.
    
    Message: Socket timed out without establishing a connection HTTP Code: TimeoutError.
    
    Message: write EPIPE HTTP Code: NetworkingError.
    

    The errors only happen after an hour or so in the backup process and files are added to my Scaleway instance. The error always pops up somewhere deep inside a gibberish directory (I think it's encrypted?) but never the same one so it seems. It's always my NextCloud instance and the directory always seems to match in some way, something like:

    snapshot/app_xxxx/....1NRyroOTEk..../....YDrvyp7W5N..../..a../..b../..c../..d..
    snapshot/app_xxxx/....1NRyroOTEk..../....YDrvyp7W5N..../..k../..l../..m../..n..

    The only thing I can think of is that I messed up my NextCloud instance a bit because I removed a file directly in the terminal, which apparently causes the instance to get confused with its database. As recommended on other NextCloud posts that I found, I ran a command to reindex my database. Something like this:

    sudo -u www-data php occ files:scan --all
    

    I ran it within the Cloudron terminal of my NextCloud instance.

    Any ideas on how to debug this problem? Is it related to the described hickup? Or is it related to Cloudron/Scaleway?

  • Staff

    Do you know if there is any network/bandwidth restrictions on your scaleway instance? And if Scaleway storage itself has any bandwidth/upload restrictions? Maybe you can ask their support if they are not immediately obvious from their pages. Looks like what is happenning is that the server is losing connectivity with the object storage. This usually happens when the network is throttled/limited somehow.


  • Thanks for your reply @girish. I contacted customer support of Scaleway and they told me they do not throttle their object storages (which is what I backup to).

    Scanning the log files, I found that it did in fact crash on a specific series of files. I think the root cause for this was that there was a single device of mine that halted on an auto-upload via the NextCloud app. I rarely use this device and did not notice it was stuck on an upload for days. I removed the files and ran another backup, this time it did not crash.

    Is it possible that the backup script can timeout on such a partial/corrupted file?

  • Staff

    @timmeh said in Scaleway backup errors:

    Is it possible that the backup script can timeout on such a partial/corrupted file?

    It shouldn't ideally. Are the files very large or special in some way?


  • @girish They are unusual I would say, yes. It's a file that is being updated on a daily basis so it has a file history of 30 different versions in NextCloud. They are .db.crypt12 files, which is a database backup of WhatsApp about 120MB in size.