Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Install own app failed with No CloudronManifest.json found


  • Staff

    We haven't really tested it on windows yet. I will do so in the next couple of days, to see if we need some special fixes there.



  • I install ZorinOS on HyperV and try it there



  • Hey,
    I did everything differently than I had planned 😊

    I have installed my first app on my instance, but i can't connect to mariadb-server.
    Yes my plan was to install a standalone mariadb-server to use it as cloud database without any connection to the internal database.

    Now I would like to test my server and I can't connect. The server runs good, the special credentials that I have created dynamically while installation works, but when I try to connect from my Client Valentina Studio on Zorin OS to the server nothing happens.

    What I'm doing wrong?

    https://bitbucket.org/roru2k20/cloudron-mariadb/src/master/

    Can anybody help me? All knowledge I have acquired autodidactically

    Thanks and have a nice evening.


  • App Dev

    @roru2k20 To use cloudrons built-in mysql server (MariaDB is mysql!) you need to add the mysql addon to the manifest. Then you will get auto-generated credentials via environment variables.

    https://cloudron.io/documentation/custom-apps/addons/#mysql

    Screenshot of how the manifest would look with it:
    ba36fac5-95f1-4729-96b1-a6c471c22f7f-image.png

    Please note the syntax - it's a JSON file and will need to be formatted properly!



  • @murgero many thanks but my plan is not to connect to the internal server. My plan is only to create a standalone server.

    Now I have installed successfully, but I can't connect to them.

    When I test the container with a portscanner only 80, 443, 22 and 222 are open. My plan is 6033.

    Screenshot_20200725-111439.png

    Is this a good plan?

    When all is fine next step is to combine with phpMyAdmin in one installation.



  • Now I have change all Ports to 6033 and I can't connect to the MariaDB-Server

    Here you can see my netstat -tulpen export
    Bildschirmfoto vom 2020-07-25 13-32-09.png

    But further my portscanner said no open Port 6033.

    What I'm doing wrong???


  • Staff

    In your case you have to specify the ports in the CloudronManifest. See https://cloudron.io/documentation/custom-apps/manifest/#tcpports for that

    Generally, what is your reason to require a standalone mysql server as an app on your Cloudron?



  • I would like to test if I can create an App for Cloudron.

    But may be as App for centralized database server for development. It is only an idea from me.

    When it successfull done I would like to test more, may be more complicated app.



  • Oh my godness...I'm so blind

    In Germany we often say: We can't see the forest for the trees. 😉

    It works great!! It was misconfiguration of my client. My client Valentina Studio thought the connection was a MSSQL-Server and not a MariaDB/MySQL. After I recreate my connection it works with the right port and use my special credentials.

    Thanks a lot for your help


  • Staff

    Glad it solved itself 🙂


Log in to reply