Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

  • Staff

    We are focusing on getting apps published these 2 weeks or so. We recently pushed out Grafana, Snipe-IT, Directus, Moodle. BBB and Calibre-Web are in the works.

    Just a heads up that we will do a patch release this week since there's a lot of bug fixes in master branch - I will leave a note here, when it's actually released.

    edit: forgot to mention that some LDAP integrations that we had not finished like for Peertube and Discourse are also in the works.

  • @girish said in Cloudron 5.6.2:


    Oooh! I figured you'd wait until 2.3 was released, but I guess you can get most of it done using 2.3alpha2 and then just update, right? 🙂

    For those thinking BBB? It's BigBlueButton

  • Staff

    @jdaviescoates said in Cloudron 5.6.2:

    Oooh! I figured you'd wait until 2.3 was released, but I guess you can get most of it done using 2.3alpha2 and then just update, right?

    @BrutalBirdie and @nebulon know about this better. My understanding is that as the first step we will just get the Greenlight package released (this is a UI for BBB). The backend server has to be installed in some other server outside of Cloudron and is then set in the Greenlight app.

    (Step 2 is of course to also have the backend packaged, not sure if @BrutalBirdie has been working on that part too ).

  • @girish ah yes, I saw @BrutalBirdie was working on Greenlight, but yeah, the really exciting bit is when BBB server itself comes to Cloudron! (which I'm not sure anyone is working on yet?)

  • App Dev

    @jdaviescoates Mmm.. bringing the BigBlueButton server into a Cloudron App.

    Maybe @luckow can share his insights, because I remember a conversation about BBB as App not being a good idea.

  • @BrutalBirdie said in Cloudron 5.6.2:

    I remember a conversation about BBB as App not being a good idea.

    It could possibly be that BBB recommends bare metal servers because freeswitch (which it depends on) works best like that?

    But at the same time I have also heard of people using BBB on a VPS without any real issue.

    I'd definitely love to have a BBB app!

    And I think that once 6.0 with it's unified dashboard (whatever that exactly turns out to be) is out it'll also be easier to have a whole separate VPS dedicated to just Cloudron + BBB, which would help too I imagine.

  • App Dev

    @jdaviescoates lets switch this conversation to the BBB app instead of the 5.6.2 topic since when reading about BBB and cloudron I doubt people checking the Cloudron 5.6.2 topic 😄

  • One of my Cloudrons recently updated to 5.6.2 and I one small gripe: the version number no longer seems to be displayed in the bottom right of the screen and I've become accustomed to seeing it there.

    Could we have that back please? 🙂


  • @jdaviescoates Yes, it was moved to the Settings > Updates menu section, but I'd still like to see it where it was.

  • @robi I'm not seeing it anywhere (just looked in Support and quite a few other places too). But yeah, I liked being able to see it without going anywhere.

  • I found it in settings and I updated the post above. 😉

  • @robi ah, yes. It was always displayed there too, I think:


    But yeah, I don't want to have to go looking for it, I want to see it perpetually down there in the bottom right 🙂

    And actually, no, I'm wrong, it wasn't there previously. This is from an install that is still on 5.6.1


    So, good that it's there as well (makes sense), but should still be back in bottom right too! 😛

  • @d19dotca thanks, how very odd. I'm really not sure why @girish suddenly proposed removing it given no one had asked for it to be removed! 🤷

  • @jdaviescoates Yeah I think it was really minor but I’m sure certainly okay with it. The footer should generally be (IMO) what WE want clients to see since the footer can be branded, so putting the version down in the footer goes a little bit against the ability to brand the footer / having control of the footer. But I don’t really care much either way, certainly never bothered me with it being there. Haha.

  • @d19dotca OK, so maybe in Branding there could be a checkbox "display version number in footer" and anyone who doesn't want it displayed there (although again I note that no one has expressed this view as far as I'm aware) could uncheck the box?

  • I updated my Cloudron server tonight to 5.6.2, and notice some strange behaviour, wanted to raise it in case it's an issue that needs to be fixed or if it's just a random issue in my environment.

    Oct 11 21:17:14 box:syncer Done processing adds null
    Oct 11 21:17:14 box:shell backup-snapshot/box (stdout): 2020-10-12T04:17:14.158Z box:backupupload upload completed. error: null
    Oct 11 21:17:14 box:backups runBackupUpload: result - {"result":""}
    Oct 11 21:17:14 box:backups uploadBoxSnapshot: took 11.439 seconds
    Oct 11 21:17:14 box:backups Rotating box backup to id 2020-10-12-041551-611/box_2020-10-12-041714-173_v5.6.1
    Oct 11 21:17:14 box:tasks 6182: {"percent":78.64117647058819,"message":"box: Copying /mnt/cloudron-backups/snapshot/box to /mnt/cloudron-backups/2020-10-12-041551-611/box_2020-10-12-041714-173_v5.6.1"}
    Oct 11 21:17:14 box:shell copy spawn: /bin/cp -al /mnt/cloudron-backups/snapshot/box /mnt/cloudron-backups/2020-10-12-041551-611/box_2020-10-12-041714-173_v5.6.1
    Oct 11 21:17:18 box:backups Rotated box backup successfully as id 2020-10-12-041551-611/box_2020-10-12-041714-173_v5.6.1
    Oct 11 21:17:18 box:updater updating box
    Oct 11 21:17:18 box:tasks 6182: {"percent":70,"message":"Installing update"}
    Oct 11 21:17:18 box:shell update spawn: /usr/bin/sudo -S /home/yellowtent/box/src/scripts/ /tmp/box-1720011772
    Oct 11 21:17:19 box:shell update (stdout): Updating Cloudron with /tmp/box-1720011772
    reset service cloudron-updater status in case it failed
    Oct 11 21:17:19 box:shell update (stdout): Failed to reset failed state of unit cloudron-updater.service: Unit cloudron-updater.service is not loaded.
    Oct 11 21:17:19 box:shell update (stdout): => Run as cloudron-updater.
    Oct 11 21:17:19 box:shell update (stdout): => starting service (ubuntu 18.04) cloudron-updater. see logs at /home/yellowtent/platformdata/logs/updater/cloudron-updater-2020-10-12_04-17-19.log
    Oct 11 21:17:19 box:shell update (stdout): Running as unit: cloudron-updater.service

    It ran into an error and so the update failed, but then it actually seemed like it worked because it's now showing me at 5.6.2 after I had refreshed the Settings page. The error from the logs: "Oct 11 21:17:19 box:shell update (stdout): Failed to reset failed state of unit cloudron-updater.service: Unit cloudron-updater.service is not loaded."

    Any ideas with the above behaviour? I may be misremembering but I seem to recall seeing the same behaviour when upgrading to 5.6.1 previously as well.

    Then the second behaviour that seemed strange (but maybe this is by design?) is that before the 5.6.2 update I had Bitwarden app update pending, when the Cloudron server 5.6.2 update was completed, then the update for Bitwarden was missing and I initially thought "oh good, it was updated at the same time too" (which kind of would make sense since the "Update" button was under the App Updates area of Settings for Cloudron). But later found that it was sort of just "reset" and needed to be checked for an update to install again on the app Updates page. Is this behaviour expected, where Cloudron updates will reset any pending app updates?

  • Staff

    Both of what you see is expected. First the reset of the cloudron-updater.service is just an attempt to fix a potentially lingering update process state. Maybe the message could be changed to not look like an error.

    The second point of available updates is because of the update states are actually cached in memory, so if the box process is restarted it looses that state. Since it checks periodically it will eventually come back (can also be triggered from the dashboard). This is purely done to avoid having to sync persistent state in the db or such.

  • @nebulon Okay, the second one makes sense. That first one though... maybe the behaviour is expected but from a UX standpoint that’s not too great to update and then see that the update failed and then only see that it actually worked after refreshing the page. If the update succeeded then there should be no failure noted to the user at all. Right? It’s basically saying “hey I failed, look at me, just kidding I succeeded”. 😆

  • Staff

    @d19dotca That "failed but actually succeeded" warning is suppressed in some parts of the code but it seems we missed the one in the update route. I have patched it now.