Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Additional Themes in Limesurvey not working


  • Hey there,
    I've been recently trying out Limesurvey. So far I enjoy it and it works quiet stable beside two issues I have not been able to fix until now.
    I really tried hard to fix the issues by myself, but since I still wasn't able to achieve what I want, I am reaching out for help. Here the two issues of which on is rather critical.

    • File Manager shows permission error upon loading.
      First I tried setting the permisions as told in the limesurvey documentation, but upon further searching I came across an open bug ticket (https://bugs.limesurvey.org/view.php?id=16212). Apparently it is a know bug and noone seems to really care... Since this the File Manger doesnt't work on their own demo (https://demo.limesurvey.org/index.php?r=admin/authentication/sa/login) I stopped searching and found a workaround.
      => In case you have a fix I'd be interested 😉

    • The critical one: Any other installed or extended Theme appears to be broken. I really want to change the default and extend a theme to make it my own. Upon opening an extended / imported / other installed theme, I get greeted with an error message in the preview window:

    ERROR!
    Calling "__tostring" method on a "stdClass" object is not allowed in "__string_template__b55aa4d0480829447d1e9202fbd9338e3599742834899f6fdab87be7c4eaab2b" at line 76.
    

    When I choose a broken theme for a survey, the survey won't display properly and the page stays blank, with a 500 internal error in the console.
    I spend multiple hours trying to fix the issue.
    My findings so far:
    It does not appear to be a permission problem, since I tried chmod 777 on the folders and files pointed out in the limesurvey documentation. My only lead so far could be a bug in the php version. I came across a limesurvey forum post (https://forums.limesurvey.org/forum/installation-a-update-issues/121252-theme-option-returns-ise-500-error-version-4-2-3-200511) where the user zlobocki pointed out that he had to change his php version from 7.4 down to 7.2. While limesurvey recommends to use version 7.4 (https://manual.limesurvey.org/Installation_-_LimeSurvey_CE) I still wanted to try it out since the container runs 7.3. Since the is mostly a read only filesystem, I was unable to change either the php version nor to modify the default themes to fit my needs (yeah I thought of that dirty trick...)

    Long story short: is there anything I can do to fix the issue and make at least the themes work properly?

    Sorry for the long text and thank you in advance!


  • I can't help unfortunately as I don't use LimeSurvey, but anything app-related should be reported in the actual category for the app (in your case it'd be this one), since it's more of a packaging / app issue rather than a Cloudron-specific issue, just for the future. 🙂

  • Staff

    @logo It seems the recommended version for LimeSurvey is PHP 7.4 per https://manual.limesurvey.org/Installation_-_LimeSurvey_CE#Make_sure_you_can_use_LimeSurvey_on_your_website . So, I have pushed a new package now that uses PHP 7.4.

    On a fresh install, I can extend themes and also edit some options. I only clicked around randomly and things seemed to work. Can you give it a test?

    fed8ad4d-dd1b-48a2-a516-4f247a5912da-image.png


  • @d19dotca Thank you, next time I will post in the right category 😉

    @girish I just gave it a test and it works like a charm! Thank you very much 🙂