Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Skip to content
  • Categories
  • Recent
  • Tags
  • Popular
  • Bookmarks
  • Search
Skins
  • Light
  • Brite
  • Cerulean
  • Cosmo
  • Flatly
  • Journal
  • Litera
  • Lumen
  • Lux
  • Materia
  • Minty
  • Morph
  • Pulse
  • Sandstone
  • Simplex
  • Sketchy
  • Spacelab
  • United
  • Yeti
  • Zephyr
  • Dark
  • Cyborg
  • Darkly
  • Quartz
  • Slate
  • Solar
  • Superhero
  • Vapor

  • Default (No Skin)
  • No Skin
Collapse
Brand Logo

Cloudron Forum

Offical apps | Community apps | Demo | Docs | Install
  1. Cloudron Forum
  2. WordPress (Developer)
  3. Wordpress upgrading, but not starting, due to missing Redis info

Wordpress upgrading, but not starting, due to missing Redis info

Scheduled Pinned Locked Moved WordPress (Developer)
2 Posts 2 Posters 47 Views 2 Watching
  • Oldest to Newest
  • Newest to Oldest
  • Most Votes
Reply
  • Reply as topic
Log in to reply
This topic has been deleted. Only users with topic management privileges can see it.
  • scookeS
    scookeS
    scooke
    wrote last edited by
    #1

    It seems Wordpress is also missing the Cloudron SSO plugin? Cloudron is 9.2, on Ubuntu 22 (server deets below). Wordpress itself has been updating from low 3.15s to the current 3.16 fine, it just won't start. I checked the credentials.txt and this is the Redis entry at the bottom:

    Redis Credentials
    =================
    
    Hostname: NA
    Port:     NA
    Password: NA
    

    I'm pretty sure I turned off or deleted that Redis option anyway, and in Services for the Cloudron it does only show one Redis for another app, but not for this one. The question is I guess, how do I edit what to fix this so it can start!? Thank you!

    Sep 26 08:30:59 => Updating redis settings
    Sep 26 08:31:00 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:31:07 Warning: The 'redis-cache' plugin could not be found.
    Sep 26 08:31:07 Error: No plugins deactivated.
    Sep 26 08:31:10 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:31:11 Warning: The 'redis-cache' plugin could not be found.
    Sep 26 08:31:11 Error: No plugins uninstalled.
    Sep 26 08:31:13 Error: The constant or variable 'WP_REDIS_HOST' is not defined in the 'wp-config.php' file.
    Sep 26 08:31:14 Error: The constant or variable 'WP_REDIS_PORT' is not defined in the 'wp-config.php' file.
    Sep 26 08:31:15 Error: The constant or variable 'WP_REDIS_PASSWORD' is not defined in the 'wp-config.php' file.
    Sep 26 08:31:19 => Updating domain related settings
    Sep 26 08:31:20 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:31:20 Success: Updated the constant 'WP_HOME' in the 'wp-config.php' file with the value 'https://futurnumerique.com'.
    Sep 26 08:31:22 Success: Updated the constant 'WP_SITEURL' in the 'wp-config.php' file with the value 'https://futurnumerique.com'.
    Sep 26 08:31:26 Success: Value passed for 'siteurl' option is unchanged.
    Sep 26 08:31:29 Success: Value passed for 'home' option is unchanged.
    Sep 26 08:31:30 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:31:33 => Install smtp mail plugin
    Sep 26 08:31:39 Plugin 'smtp-mailer' activated.
    Sep 26 08:31:39 Success: Activated 1 of 1 plugins.
    Sep 26 08:31:39 => Configuring smtp-mailer plugin
    Sep 26 08:31:40 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:31:43 ==> Configuring smtp-mailer plugin for https://futurnumerique.com
    Sep 26 08:31:49 Success: Value passed for 'smtp_mailer_options' option is unchanged.
    Sep 26 08:31:49 => Creating credentials.txt
    Sep 26 08:31:50 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:32:00 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:32:02 Plugin 'daggerhart-openid-connect-generic' activated.
    Sep 26 08:32:02 Success: Activated 1 of 1 plugins.
    Sep 26 08:32:05 Unpacking the package...
    Sep 26 08:32:05 Installing the plugin...
    Sep 26 08:32:05 Removing the old version of the plugin...
    Sep 26 08:32:06 Plugin updated successfully.
    Sep 26 08:32:09 Success: Installed 1 of 1 plugins.
    Sep 26 08:32:10 => Healthcheck error: Error: connect ECONNREFUSED 172.18.19.133:80
    Sep 26 08:32:13 Warning: Failed to activate plugin. Cloudron SSO requires 1 plugin to be installed and activated: OpenID Connect Generic. .
    Sep 26 08:32:13 Error: No plugins activated.
    

    A life lived in fear is a life half-lived

    1 Reply Last reply
    0
    • humptyH
      humptyH
      humpty
      wrote last edited by humpty
      #2

      All my WP sites are working fine on the latest package, but they're all non-SSO (users are app managed). I checked the redis info on one of my sites and there are values set in the credentials.txt. Just to confirm, this is the wp redis plugin: https://wordpress.org/plugins/redis-cache/

      I'd retoggle the redis autoconfiguration in CR dash > wordpress app settings > services

      If you want to use redis, enable the redis mentioned above, install the plugin I linked, and restart the app.

      If you want it off, delete the plugin altogether via the file manager, and make sure any other wp plugins (e.g. w3 total cache, wp-rocket, etc) don't have the redis option enabled either. Then, toggle off the redis autoconfiguration in the app's services tab and restart the app.

      edit: this is the openid plugin required for CR SSO to work: https://wordpress.org/plugins/daggerhart-openid-connect-generic/

      1 Reply Last reply
      2

      Hello! It looks like you're interested in this conversation, but you don't have an account yet.

      Getting fed up of having to scroll through the same posts each visit? When you register for an account, you'll always come back to exactly where you were before, and choose to be notified of new replies (either via email, or push notification). You'll also be able to save bookmarks and upvote posts to show your appreciation to other community members.

      With your input, this post could be even better 💗

      Register Login
      Reply
      • Reply as topic
      Log in to reply
      • Oldest to Newest
      • Newest to Oldest
      • Most Votes


      • Login

      • Don't have an account? Register

      • Login or register to search.
      • First post
        Last post
      0
      • Categories
      • Recent
      • Tags
      • Popular
      • Bookmarks
      • Search