Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Mattermost config cannot be updated

  • Staff

    @csilvav yes, as @fbartels said, you should be able to edit /app/data/config.json using the web terminal. Let us know if that doesn't work. You have to restart the app as well for the changes to take effect.

  • I have a similar issue. My attemts failed to change the config.json file in the terminal. The vi command returns a "readonly file" and I cannot change the permissions. Neither with chmod or with ls. Also mount doesn't work.

    Running the CLT I got this result:
    sudo -u cloudron /app/code/bin/mattermost config set PluginSettings.EnableUploads true
    Error: failed to initialize config store: failed to load: failed to persist required changes after load: failed to write file: open /app/code/config/config.json: read-only file system

    For the mount command I got the report that I don't have the permissions to do that.

    It is a clean new installation. No imports or anything, just the plane Mattermost.

  • App Dev

    @leon said in Mattermost config cannot be updated:


    Edit the config from /app/data/ not /app/code/

  • @murgero thank you. This one works 🙂

  • App Dev

    @leon Glad to hear! But just an FYI, if you read the comment right above yours, you would have found your answer sooner. Really happy to help though!

  • @murgero now as you said it I see it. I was focussed on the terminal use mentioned in the comment above not about the path. I'll keep that for reading more critically in the future. I'm new to Cloudron but besides that minor issue here everything works great.

  • Keep in mind that most of the good features are Enterprise only. The Team version lacks any permission policy so everyone is able to invite, delete channels and so on. See pricing-feature-comparison. For this reason most projects I know and even the company I work for uses Rocket or Riot/Matrix.

  • Hi Team,
    i could edit the config.json in /app/data/ ("EnableUploads": true,), but I still cant upload any plugin ( I have restarted the app, it doenst work.

    I also tried to upload a plugin via sudo -u cloudron /app/code/bin/mattermost plugin add com.github.scottleedavis.mattermost-plugin-remind-0.4.4.tar.gz, but it doenst work as well:

    root@c0749861-87cc-4103-a2d0-a309353d423d:/tmp# sudo -u cloudron /app/code/bin/mattermost plugin add com.github.scottleedavis.mattermost-plugin-remind-0.4.4.tar.gz
    {"level":"info","msg":"Server is initializing..."}
    panic: failed to apply option: failed to apply Config option: failed to load: failed to persist required changes after load: failed to write file: open /app/code/config/config.json: read-only file system

    Can you help me?

  • Staff

    @smichna you likely have to run the mattermost cli tool with:

    sudo -u cloudron /app/code/bin/mattermost --config=/app/data/config.json ...

  • Thank you, that works. But why I cant upload plugins via GUI although I have set the right setting (