Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


  • App Dev

    Hi there! Just tried to customize the not-responding template by creating a file in /home/yellowtent/boxdata/custom_pages/app_not_responding.html as suggested here, but it doesn't seem to get registered. I did chown the folder with yellowtent and even restarted the server, but neither seemed to have done the trick. Am I missing something?

  • Staff

    A server restart should not have been required. Can you check your nginx logs? Also just to make sure, that page should also be served up when you simply stop a working app. Just for testing the custom page here.

  • App Dev

    Yea the reboot was just to make sure, I only restarted box before, that didn't work so I tried restarting the server. I've tried by restarting an app instead of stopping it, but it's probably the same thing with either option.

    What exactly am I looking for? (sidenote: system/nginx/logs is empty and "Download Full Logs" results in a 404.)

  • Staff

    @msbt I suspect this is because the app is not using the latest nginx config. Go to the Location view and just click save to re-generate the latest nginx config. After that, stop the app and you should see the not responding page.

  • App Dev

    nice catch @girish, I need to regenerate each app config manually, then it works. is there a global cmd to regenate all at once?

  • Staff

    @msbt unfortunately, no. But new apps will get latest config.