Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Mailtrain RSS Campaign + Wordpress



  • Hello,

    I'm having some difficulty setting up mailtrain with wordpress.

    1. my server's ip address seems to be blocked, presumably because some previous DO user was spamming?
    2. when I try to use my site's wordpress feed, I get an error:
      ddf305fd-04c2-4ff0-b90f-2b0a6093938a-image.png
    3. I noticed there is a mail plugin for wordpress already - do I even need mailtrain in that case? I was not able to get it to work because of (1) above though

    I assume that the error means that mailtrain does not like the ssl cert that my little cloudron instance is using? Is it self-signed, or does it use something like LetsEncrypt?

    Does anybody have any hints about how I should approach these?


  • Staff

    @homesteadsaga said in Mailtrain RSS Campaign + Wordpress:

    my server's ip address seems to be blocked, presumably because some previous DO user was spamming?

    Yes, you have to then setup an Email relay in the Email view of Cloudron. The apps will automatically start using the relay to send email without any extra configuration.

    when I try to use my site's wordpress feed, I get an error:

    Is this inside mailtrain? Where does that screenshot come from?

    I noticed there is a mail plugin for wordpress already - do I even need mailtrain in that case? I was not able to get it to work because of (1) above though

    You probably do not. Note that mailtrain is only required to send and manage newsletters (for example, to put unsubscribe links in your email etc). If you just want to send email, the wordpress app should work without requiring any configuration. I suspect it cannot send mail because of the problem in 1.

    All certs are Let's Encrypt. The SSL issue appears to be something else but I am not 100% sure. Can you tell us a bit more high level of what you are trying to do and we can help out.



  • @girish The screenshot was within mailtrain.

    I have the email partially working now: it can receive email and I can read it on thunderbird, but I haven't been able to successfully send one yet. Some of the logs say something about the domain being too new.

    I'll try the wordpress built-in email for now and see how far I get