Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Pixelfed Not Federating



  • Just setup pixelfed, its not federating. The failed jobs page says no failed jobs. I'm running this from photos.domain.com.


  • Staff

    @will Have you see this doc? The crucial part is that you can only see posts that are made after you followed the handle. Already existing posts are not seen. Bit unfortunate that but that's how it works.



  • @girish I can't even see the user account.
    It worked previously, when it was first being tested. Could old mastadon/riot settings on the host be messing with it?


  • App Dev

    @will ... I've got Mastodon and Riot up and running with Pixelfed, no issues. Feel free to search for me @doodlemania@pixels.thedoodleproject.net ... when you do the search, watch your logs and it should show up after a few tries.



  • @doodlemania2 said in Pixelfed Not Federating:

    @doodlemania@pixels.thedoodleproject.net

    Just followed you. But something seems off. I could search for you as a user, but when I am in Pixelfed and can see those Following me, I can't follow them back from within Pixelfed Followers view. When I click on a Follower it brings me to their instance, but I can't Follow them back. In fact, I'm urged to make an account on their instance! Weird.


  • Staff

    @will AFAIK, the mastodon/riot settings have no overlap with pixelfed. Not sure what might be going wrong.


  • App Dev

    @scooke I'm not 100% certain, but this might be the way Pixelfed currently works. I've seen this experience myself and it is a bit sub-optimal, but doesn't appear related to cloudron or the federation but rather, the app itself. Will continue to monitor!



  • @doodlemania2 I was able to see you in mastadon and pixelfed! Anyone have a peertube instance I can test? Also, how can I test Element chat federation?

    Thanks guys!


  • App Dev

    That's great @will ! I think we'll have GNU-Social too fairly soon as it's marked #wip



  • @will yes I'm testing one here : tube.okcinfo.news



  • @scooke can't you remote follow them from your instance ?
    I agree with the other comment, you can't use Pixelfed as a full blown actor in the fediverse, you can follow other users in your pixelfed instance but any user outside of your instance is a remote follower you can follow from your mastodon account but not from pixelfed.
    on the other end, anyone using an activitypub enabled system can follow a pixelfed user.



  • @will I have the same issue.
    There is not a single error in my horizon dashboard, it's active & green, following your own pixelfed user from your mastodon instance work just fine but if you search a profile from another PIXELFED instance anywhere in the fediverse there is no search results
    d7086b68-8441-43ab-8fc6-8e2497a8aaf0-image.png

    https://pixelfed.social/admin

    If you look to your own mastodon or any other identity there is no issue :
    88e9ccc5-f588-42b2-9c91-0499ee07eb93-image.png
    d2d45a87-6400-4163-bc0d-4d0a916aabea-image.png

    it can't neither see a peertube profile.



  • regarding no errors in Horizon :

    There does not seem to be any jobs running, maybe that's why ?
    14e192e5-36f4-43fc-a4b0-7bdfb64aa7af-image.png
    no jobs no failed jobs ?
    705c38c3-877c-484e-b91f-ee3e896b8f9a-image.png
    earlier today I published a photo from my mobile and it went just fine :
    239f5498-a276-4d8e-808d-072cb53f9b94-image.png
    https://pixel.rmendes.net/p/rmdes/194086913265766400

    My experience is that the app is smooth and fast both on desktop and mobile
    I have no idea what's going on but when I search admin@pixelfed.social
    in the logs trail you can catch this :

    Jul 29 17:54:25 172.18.0.1 - - [29/Jul/2020:15:54:25 +0000] "GET /api/search?q=admin@pixelfed.social&src=metro&v=1&scope=profile HTTP/1.1" 200 992 "https://pixel.rmendes.net/i/results?q=admin%40pixelfed.social" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"
    Jul 29 17:54:25 172.18.0.1 - - [29/Jul/2020:15:54:25 +0000] "GET /api/pixelfed/v1/accounts/verify_credentials HTTP/1.1" 200 1555 "https://pixel.rmendes.net/i/results?q=admin%40pixelfed.social" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"
    

    this "verify_credentials" might be where the problem is ?



  • @rmdes I followed somebody outside my instance.


  • App Dev

    I wonder if this is a Pixelfed issue, not a Cloudron issue? It seems some types of follows work, others not so much. Thoughts?



  • @will Do you mean another pixelfed user or another user from another activitypub enabled service (mastodon, pleroma etc..)



  • @rmdes I can't see other users on PixelFed, like browsing their pages.


Log in to reply