Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Does Cloudron support Remote SQL



  • Does anyone know if Sequel Pro would work with Cloudron's app containers via it's SSH feature:

    Screen Shot 2020-09-26 at 3.37.45 PM.png



  • @Lonk I use Sequal Pro with the standard host/user/pass credentials. I think only certain apps have the DB available for external connection though, like LAMP/Wordpress:

    https://docs.cloudron.io/apps/lamp/#configuring-mysql



  • @marcusquinn I just tried and couldn't get Sequel Pro to work with my Wordpress Unmanaged Installation. Which option did you have to choose at the top?

    Screen Shot 2020-09-26 at 6.10.13 PM.png



  • Thinking my ageing memory got mixed up with FTP via Transmit 😬 Even that I think is limited to only a few apps.



  • @marcusquinn I have a feeling I can get it working via the SSH tab. I just hope it'll be as fast as I'm used to.

    I also use Transmit, love it! And yes, not all apps on Cloudron allow for SFTP, but luckily Unmanaged Wordpress is one of them!



  • I did not get it working over SSH. Technically it could work. But after SSH-ing into my VPS I need Sequel Pro to run cloudron exec to enter in the Wordpress sub-container (what Cloudron’s base code calls Cloudron apps). It tries to open MySQL straight from the SSH root. I wonder if I can set up a username that auto-logs into my Wordpress installation.

    I had a hell of a time trying to change my main domain name for my Wordpress installation yesterday. I couldn’t do it from within Wordpress because the tool would break before it was finished. The subcontainer broke entirely. I had to clone it to its original domain and then terminal in to write pure SQL (I hate doing that) to edit the domain. If I can’t get Remote SQL working then I’d love to get PHOMyAdmin working on the official Wordpress app.



  • @Lonk Yeah, of course the Adminier WP plugin option only works if WP is running. I feel we're going to discover a few things when we come to bring the Brandlight stack into being a Cloudron App, so following your adventures with interest.



  • Oh, I just meant I couldn’t change al the 5 domain URL entries (the only way to do it) in the database from within the Wordpress app before it crashed so I had to do it within the pseudo-terminal of a cloned backup (since I botched the initial installation so bad it couldn’t even be restored 😅).


  • Staff



  • Hey everyone who is reading this, @girish gave me the commands necessary to get this working in:

    https://forum.cloudron.io/topic/3237/remote-sql-support-on-a-per-app-basis

    So, if you need Remote SQL support, that's the place to go! ☺



  • @Lonk Domain changes for apps happen at the Cloudron My Apps dashboard level, not within the app. You change it there, and it basically reinstalls, or reconfigures, everything for you.

    If I've understood correctly, Cloudron doesn't work like other "dashboards" that simply let you install an app that you then manually manage. Cloudron is not just the gateway, it is the gatekeep too (I have no idea if that makes sense!). In the main My Apps window you can hover over the top most right-sided icon in an app box, with the gears, and see Config. Once in the next window you can change all kinds of details. Changing the domain is the second item down from the top on the left-side menu, somewhat confusingly called Location (rather than domain - but since it could be a tld or a subdomain I guess Location is as good a term as any). Changing any config will then basically relaunch the app, and reconfigure it. It took me a few times to realize this and to thus try to plan my config changes so that I didn't have to relaunch the app 3 or 4 times after each tweak!



  • @scooke Yes yes, that's how it's supposed to work, correct. It doesn't work that way with Wordpress Multisite. You change the domain on Cloudron and the whole app breaks. I'll be fixing that in a future update to the Wordpress Unmanaged App package tho since that's the app I really want to work on. ☺


Log in to reply