Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

SOLVED Looking for a networking expert

  • App Dev

    This is only tangentially Cloudron-related, sorry ^^

    I recently had a nice Fiber upgrade in my home, and I'm considering now hosting my Cloudron at home instead of a rented server. But before doing that, I wanted to setup a proper home network instead of the crappy ISP router. So I went with an OpenWRT setup.

    However, I'm running into a bit of trouble with the IPv6 routing. I managed to setup Prefix Delegation. My computer does get assigned a public IPv6.

    From the OpenWRT router, I can ping6 the outside world.

    From my computer, I manage to ping6 machines in my local network and my OpenWRT router. However, I cannot ping6 outside my local network : I get Destination unreachable: No route.

    I tried multiple ways to make my OpenWRT router route IPv6 traffic correctly, but to no avail. I'm not sure what I can try next.

    If there's any networking guru / OpenWRT expert in the Cloudron community, any help would be hugely appreciated !

  • Staff

    Have you tried something like and ? I recall @nebulon telling me that even though his ISP gave him an IPV6 addresses, it ultimately uses IPv4 which is shared in his full building or something. Can you check if the outside world actually sees your IPv6 for a start?

  • Staff

    I would love to go all IPv6 myself but atleast here it's all still IPv4 😕

  • @girish said in Looking for a networking expert:

    I would love to go all IPv6 myself but atleast here it's all still IPv4 😕

    you can practice with Tunnelbroker from

    They even have a free certification to help you learn and level up.

  • First, you'll have to share your OpenWRT configuration.

    Generally you'll need DHCPv6 running so your LAN side devices get autoconfigured with a v6 IP including default gateway.

    Next question, how did you configure v6 on your LAN PC, expecting it to ping your router and WAN v6 hosts?

  • App Dev

    A few details about my setup:

    I'm at Free (the french ISP), using the Freebox Pop router.

    The ISP router is connected to my OpenWRT box, which then serves the local network.

    For IPv4, the ISP router just "gives" the public IPv4 it receives to the OpenWRT routeur through DHCP on its WAN port => it just works.

    For IPv6:

    • The ISP router has access to 8 ranges:
      • 2a01:XXXX:XXXX:XXX0::/64
      • 2a01:XXXX:XXXX:XXX1::/64
      • ...
    • The first range is announced by the ISP router on its own subnet, and it is not recommended to change anything about it
    • For the other ranges, the ISP router offers the possibility to configure a "Next Hop".
    • Following multiple tutorials online, I setup as the "Next Hop" for the 2a01:XXXX:XXXX:XXX1::/64 subnet the local-link address of my OpenWRT router, and added said subnet as "Custom delegated IPv6-prefix" on the WAN6 interface of the OpenWRT router.
    • Now my machines do recieve a public IPv6, can ping each other, but not the outside world. According to the tutorials, it's normal I just have to add some static routes. However, I do add them and it's the same. => "No route to host"

  • App Dev

    Dammit, going through the details of the tutorials to explain each step I did, I noticed that I forgot to enable the "Always announce default router" option on the LAN interface -_- looks like it works now... Sorry for the bother !

  • Staff

    @mehdi Seems like a classic case of Rubber ducking (some funny discussion here -

  • App Dev

    @girish I did not know the term. I certainly did know the effect ^^ (I might have to invest in an actual rubber duck... maybe they are especially effective)

Log in to reply