Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Interesting WARNINGs in the Kutt App Logs


  • Mainly Redis related..

    Check yours..

  • Staff

    Nov 10 13:05:05 15:M 10 Nov 21:05:05.039 * Running mode=standalone, port=6379.
    Nov 10 13:05:05 15:M 10 Nov 21:05:05.039 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
    Nov 10 13:05:05 15:M 10 Nov 21:05:05.039 # Server initialized
    Nov 10 13:05:05 15:M 10 Nov 21:05:05.039 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
    Nov 10 13:05:05 15:M 10 Nov 21:05:05.039 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
    

    I think https://forum.cloudron.io/topic/2721/please-disable-transparent-hugepage . Upstream didn't respond, the warning can be safely ignored.