Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Skip to content

Kimai

14 Topics 184 Posts
  • Kimai - Package Updates

    Pinned
    121
    0 Votes
    121 Posts
    5k Views
    nebulonN

    [2.9.6]

    Update Kimai to 2.15.0 Full changelog Added "api_access" permission for limiting API access (#4779) Added several _process dates to invoice hydrator (#4749) Added activity.number and project.number to invoice hydrator (#4749) Added activity.invoice_text and project.invoice_text to invoice hydrator (#4749) Fix Cannot redirect to empty URL SAML issue (#4761) Simplify 2fa (deactivation) form (#4749) Clarify expected datetime format in API docs (#4749) Allow to order by activity and project number (#4760) Do not store hashed password for LDAP and SAML users (#4755) API tokens not working with certain Apache configurations (#4774) Dashboard widget "my working times" calculation behavior changed (#4749) Catch Throwables if curl_multi_exec is disabled (#4740) Fixed several deprecations (#4749) Fix "invoices" internal menu name
  • 403 error when embedded

    2
    1 Votes
    2 Posts
    17 Views
    murgeroM

    First thing that comes to mind is this: https://docs.cloudron.io/apps/#custom-csp

  • Custom Content plugin requires build Kimai 20100 or 20500

    Unsolved
    3
    0 Votes
    3 Posts
    45 Views
    foliovisionF

    Thanks @nebulon for the quick answer. It does look like you are shipping a more recent version than the internal version number suggests. We'll have another go at it tomorrow to try to figure out why the Cloudron version reports an earlier version number than
    CustomContentBundle-2.2.0 and
    CustomContentBundle-2.3.0 allow.

  • ERR: invalid Kimai minimum version

    Solved
    7
    0 Votes
    7 Posts
    315 Views
    chymianC

    @nebulon, according to the author, @kevinpapst, the plugin is no longer needed and as a left over within the cloudron installation causing problems.

    I moved it out of the way and everything is back to normal.

    cd /home/yellowtent/appsdata/<UUID</data/plugins mv RecalculateRatesBundle .RecalculateRatesBundle or rm -rf RecalculateRatesBundle
  • Kimai version 2

    Solved
    8
    3 Votes
    8 Posts
    219 Views
    andreasduerenA

    @nebulon I mean adjusting the plugins as described here

    Screenshot 2023-03-06 at 9.02.57 AM.png

  • Error while installing Kiosk Plugin

    Solved
    4
    0 Votes
    4 Posts
    229 Views
    subvenS

    @girish yepp works now 🙂 Thank you for taking care of the package.

    rtjtrzj.png

  • Templates

    5
    0 Votes
    5 Posts
    317 Views
    girishG

    @subven Fair enough. If other people stumble on this, maybe we can make a default directory for templates.

  • HTTP ERROR 500 when accessing "Weekly working hours" page

    Solved
    9
    0 Votes
    9 Posts
    513 Views
    N

    @girish Looks like that fixed it. No more loading issues, and no more log errors. Thanks!

  • 0 Votes
    4 Posts
    327 Views
    nebulonN

    This is now fixed in the latest package.

  • Looking for UserIDs

    Moved Solved
    3
    0 Votes
    3 Posts
    282 Views
    L

    Thanks! That was exactly what I was looking for 🙂

  • Mixed content warning while embedding

    Solved
    4
    0 Votes
    4 Posts
    324 Views
    subvenS

    Works 🙂 Many thanks!

  • Kimai - settings: 500 - Error

    Moved
    6
    0 Votes
    6 Posts
    686 Views
    luckowL

    My workaround: delete the content of the local.yaml.
    https://github.com/kevinpapst/kimai2/issues/1290

  • Kimai - public/avatars not writable

    Moved Solved
    3
    0 Votes
    3 Posts
    160 Views
    nebulonN

    Solved with the latest app package release today

  • Kimai local.yaml

    Moved Solved
    5
    0 Votes
    5 Posts
    518 Views
    S

    hi all,

    i managed to make the changes, i had two mistakes:

    i had to clear the kimai cache via terminal (it is in the kimai docs)
    https://www.kimai.org/documentation/configurations.html

    when trying to clear, so the effects take place, i got an error. apparently you cannot use tabs as indentation, so my local.yaml was not readable anyway

    after using spaces and clearing successfully the cache, every worked 🙂

    thanks for the help!