Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now. (communication)

  • @girish said in (communication):

    This is almost working now - (based off @msbt 's work)! I am testing out the federation bits, after that I will get this published.

    I assumed federation support would be very tricky for cloudron but than I saw how you managed stuff like federation port and well.known 🙂 Hope you have fun with the federationtester ^^ Are you using ma1sd or mxisd?

    We "fixed" it with a nginx that proxy passes requests on any hostname with path /.well-known/ to 😧

  • Staff

    @subven Yes, I am not 100% sure if the configuration I have actually works (for federation) but in theory it should. For the well-known, we are looking into adding this to Cloudron itself (probably in the domains view). We can then do mail auto-discovery, mastodon etc.

  • @girish said in (communication):

    @subven Yes, I am not 100% sure if the configuration I have actually works (for federation) but in theory it should. For the well-known, we are looking into adding this to Cloudron itself (probably in the domains view). We can then do mail auto-discovery, mastodon etc.

    Heads up for adding the well-known to the root domain! As you said, this would add autoconfig for mail as well which would be great. Not quite sure if this could be added as a configurable feature for Caldav for example, as users could use different Caldav server (Sogo, Nextcloud, etc.)

  • for people using my matrix installation: if you're on the latest cloudron version (>=5.1), you need to disable the turn port, else it will prohibit the real turn service to start up because the main port is in use.


  • @yusf said in (communication):

    Will there be an upgrade path from msbt’s package?

  • @msbt Thanks for the work you put in it!
    I have successfully deployed the app, it was necessary do edit CloudronManifest.json and remove the udp ports there.
    Do you know how the postgresql db can be edited to make a user an admin? I would like to follow the documentation here:

  • You're welcome! I'd rather wait until the cloudron package is final before tinkering around 😉

  • Staff

    I managed to get federation working just now, yay! I will make matrix available tomorrow 🙂 It does require a new Cloudron release for well-known support.


  • 2cab1b67-ac11-4463-9374-678be17eb6ec-image.jpeg

    That feeling when something you’ve wanted for years finally realizes.

  • First of all, thanks to everyone who has been working on the matrix app. I'm very happy to be able to run it on cloudron! 🙂 👍
    I have two questions/points that I would like to discuss and hope this is the right place:

    1. Setting up the root-domain for federation use.
      When installing matrix synapse it is necessary (at least for me) to set the root domain ( as a redirect URL for to make federation work. As far as I know only port 8448 is needed on the root-domain to make federation work. Using my workaround I am not able to use another app with the root domain (e.g. a website or any other service). Is there any way to avoid this?

    2. Making a user an administrator.
      Referring to the documentation ( one command needs to be executed to make a user an admin - it manipulates the data in the postgresdb:
      UPDATE users SET admin = 1 WHERE name = ''
      What is the recommended way to perform this on Cloudron?

    Thanks a lot in advance.
    Stay healthy everyone!

  • I installed a test-instance as well on a subdomain and neither federation nor the integrations are available. @girish ping me on the chat for debugging 😉

  • Staff

    @stantropics What can an admin do? Does he get some special controls in Riot? I couldn't figure out how to test it, so I left that part out.

  • @msbt The RIOT First Time Documentation notes that you need to tweak the Matrix Synapse home server. I found that the install uses the domain you give it but assumes 'matrix' is the subdomain. My subdomain was different and I had to tweak both the Matrix Synapse config and the RIOT config and then I restarted both, Then it worked. Check out the little drop-down tab "Documentation" and the First Time Setup, and follow the links there. I hope the issue is this simple.

    First Time Setup
    This app is only the frontend for Matrix. If you haven't done so already you should install the Matrix Synapse home server in a subdomain like

    This app is pre-configured to use the matrix installation at If you installed Synapse at another location, use the Web Terminal to edit /app/data/config.json to set the home server.

  • Staff

    I just announced this - . Can you guys give it a quick read and tell what to improve there?

  • @girish Do you want the comments here? All I can say is that this section:

    Riot is pre-configured to use matrix subdomain as the homeserver location.

    ought to be more evident. Like at the start of a paragraph. It's the sort of essential info that real coders like yourself just know but tinkerers like me don't.

    Another line that could use some clarifying is:

    SSH into the server and add the record like this

    My own impression from using Cloudron is that there is no need to ssh into the server and that using the built-in Terminal is the place to get things done if needed. I followed it literally, but I also think someone could read it and think "they must mean through the Console of the app...but which one, the Matrix server or the RIOT app?" and proceed to get confused because they can't navigate to


    Finally, in Step 3, after the line:

    If you installed synapse at, the client should be already able to connect

    maybe you could add something like "check Step 1" as a reminder because someone will prob skip it and then get here wondering what's going on.

    Finally, thank you again.

  • everything works fine now, no idea what caused the issues, all good, thanks @girish

  • Staff

    @scooke Thanks for the feedback, will fix up the docs.

    The SSH is a bit rough agreed 🙂 We will add a UI for .well-known records in the coming releases. For now, we wanted the apps out, so we can get some testing in parallel.

  • @msbt do you also have to set a redirect record for to make it work? Or is it just me?

  • Staff

    @stantropics You don't need to setup redirects. Is the website an app on Cloudron (or is it external to Cloudron) ? If it's the former, you just have to setup that .well-known record.

  • @stantropics I had a surfer app at and curl'ing the well-known url gave me a 404. After a bit of reconfiguring it worked, not sure if that's your setup as well, but maybe try reconfiguring the app and see if that solves your issue (if that's what you're asking)

Log in to reply