Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED matrix.org (communication)


  • @girish Do you want the comments here? All I can say is that this section:

    Riot is pre-configured to use matrix subdomain as the homeserver location.
    

    ought to be more evident. Like at the start of a paragraph. It's the sort of essential info that real coders like yourself just know but tinkerers like me don't.

    Another line that could use some clarifying is:

    SSH into the server and add the record like this
    

    My own impression from using Cloudron is that there is no need to ssh into the server and that using the built-in Terminal is the place to get things done if needed. I followed it literally, but I also think someone could read it and think "they must mean through the Console of the app...but which one, the Matrix server or the RIOT app?" and proceed to get confused because they can't navigate to

    /home/yellowtent/boxdata/well-known/
    

    .
    Finally, in Step 3, after the line:

    If you installed synapse at matrix.example.com, the client should be already able to connect
    

    maybe you could add something like "check Step 1" as a reminder because someone will prob skip it and then get here wondering what's going on.

    Finally, thank you again.

  • App Dev

    everything works fine now, no idea what caused the issues, all good, thanks @girish

  • Staff

    @scooke Thanks for the feedback, will fix up the docs.

    The SSH is a bit rough agreed 🙂 We will add a UI for .well-known records in the coming releases. For now, we wanted the apps out, so we can get some testing in parallel.


  • @msbt do you also have to set a redirect record for example.com to make it work? Or is it just me?

  • Staff

    @stantropics You don't need to setup redirects. Is the website example.com an app on Cloudron (or is it external to Cloudron) ? If it's the former, you just have to setup that .well-known record.

  • App Dev

    @stantropics I had a surfer app at example.com and curl'ing the well-known url gave me a 404. After a bit of reconfiguring it worked, not sure if that's your setup as well, but maybe try reconfiguring the example.com app and see if that solves your issue (if that's what you're asking)


  • @msbt @girish I am not using the root-domain (example.com) at all currently. But matrix seems to not work if I don't set it up as a redirect for matrix.example.com.

  • Staff

    Can you post your setup here with example domain names of where you installed what - https://forum.cloudron.io/topic/2336/matrix-riot ? I can help out there.

    I will lock this thread, since 2 open posts for the same topic is confusing!


  • @stantropics In the terminal you should be able run the psql command to update a user to admin.
    To get the password type:
    echo $CLOUDRON_POSTGRESQL_PASSWORD

    psql --host=$CLOUDRON_POSTGRESQL_HOST port=$CLOUDRON_POSTGRESQL_PORT $CLOUDRON_POSTGRESQL_DATABASE $CLOUDRON_POSTGRESQL_USERNAME

    [right-click-Copy and ctrl-v paste in the password]

    UPDATE users SET admin = 1 WHERE name = '@foo:bar.com';

    BUT: I am getting: psql: FATAL: password authentication failed for user ...

    Can anyone see what I am doing wrong? @girish ?

  • Staff

    @jimscarver In the Terminal, there is a Postgres button on the top. Just clicking it will paste the command to connect to postgres. Just paste enter after that.

    511da217-1649-4dcf-a58a-7e0a34201df4-image.png

    (That aside, I think the mistake in your cli is possibly that the database name is not set)