Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Update 2.1 Stuck at "Downloading and installing new version"


  • The Cloudron update from 2.0.1 to 2.1 (or 2.1.1?) stays stuck at "Downloading and installing new version" for 12+ hours (at which time I reboot the server so I can get the dashboard back). It has done this at least 3 days in a row. I have only around 40GB on the server. The server seems to work fine, other than this update issue.

    Any advice on how to proceed? I have a Pro subscription, if that makes any difference on how to proceed (automatic updates, etc).

  • Staff

    @FTLAUDMAN can you check if you are hitting https://forum.cloudron.io/topic/1305/cloudron-2-1-released/3 . Also which vps provider are you using?

    If that doesn't work, can you add our support keys and we can take a look.

  • Staff

    @FTLAUDMAN If you check journalctl -fa and it shows something like below over and over again:

    The following packages have unmet dependencies:
     docker-ce : Depends: libseccomp2 (>= 2.3.0) but 2.2.3-3ubuntu3 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    To fix:

    apt update
    

    You might have to run the above command a couple of times since it might says it cannot get the lock. Once the update is done, it should update automatically.


  • @girish Thanks for the helpful suggestions. I haven't had a chance to try this yet, but I should have time after work. I am using a dedicated server (8 core, 16GB RAM, 250GB SSD) running Ubuntu 16.04 through Online.net.


  • @girish The update worked! The first steps didn't work for me, but the apt update did the trick. Thank you!