cloudron-setup has no documentation for "provider" options

  • Trying to get started, as the promise of Cloudron is to provide self-hosting for cloud services (at least, as I was pitched 😉 ). Less than zero interest in using any cloud server provider.

    The first thing required by the Setup script -- before you can even get the script to run -- is a "provider" option. However, there's no documentation W H A T S O E V E R for this option. I tried "--help" at first to see if it would explain the options, or even what the question is asking (is it asking for a music service provider? internet service provider? food service provider? ELABORATE on the question, please!).

    I had no direction to what to pick or when to pick the "Generic" option. Didn't even know what that means, and I also didn't know what 9/10 of the available options were even referring to.

    I know my domain is bought through Godaddy, so I was looking for the Godaddy DNS option there, as the docs dive head-first from "run this command line with options a/b/d/g/b/sb/sdf/generic and when it comes back, read on!", right into DNS options, so I thought it was referring to DNS.

    Could you just take a few minutes and write a couple more lines in this page explaining what the heck the "provider" option refers to?

  • @FalconFour Thanks for trying us out. It's clear that I wrote the docs making many assumptions about the reader 🙂

    provider is just a flag to indicate where your VPS or server is located. If it's not in the list, just choose generic. So, the install is simply:

    ./cloudron-setup --provider generic

    No other options are required.

    For some background, when we started Cloudron, we had to put in a lot of hacks for every infrastructure provider out there. The ubuntu on hetzner was slightly different from ubuntu on aws was slightly different on OVH and so on. So, the setup script had a bunch of hacks based on the 'provider' argument passed to it. AFAIK, there is no way to automatically determine where a server is running i.e if it's on OVH/Hetzner/DO/AWS. Today, we don't use that flag at all but it's still there in case we need to put in some hacks 🙂

    After the install script finishes running, it will reboot the server. After the reboot, visit https://IP in the browser. At that point, you can put in GoDaddy information.

    Hope that helps! I will fix the docs to provide above info.

  • Woohoo! Yep, I set it up with the "generic" option. Almost immediately ran into an issue with the installer backgrounding a text-UI yes/no prompt that it never answered (so it hung), with the UI written into the log file hovering over the "no" box... but... after Ctrl+C'ing out of it and trying again, it worked.

    Now I'm stuck trying to get cert set up. Let's Encrypt seems not to be responding... just hangs at "renewing certs" and visibly 1% on the progress bar forever. Hmm...

  • OK, we got this sorted out 🙂

Log in to reply