Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.



  • It seems like something's wrong with the latest round of updates. I'm on OnlyOffice 5.5.1 (Package v1.1.1) and Nextcloud 18.0.2 (Package v4.4.0). When I try to load a document or spreadsheet, I get a notice that the "editor version has been updated" and the page tries to reload but never does (see below).

    I've tried restarting both NextCloud and OnlyOffice, tried reinstalling OnlyOffice, tried a different browser, and double-checked the configuration steps from the Cloudron docs -- none of these seems to have fixed it. Has anyone else noticed a similar issue?

    Screenshot_2020-04-13 kpis xlsx - Nextcloud(1).png.

  • Staff

    @ochoseis I don't know the root cause but one idea is to disable/enable the onlyoffice extension inside nextcloud and also clearing the browser cache?


  • Clearing cache and trying logging in/out didn't work. Figure it might be an issue with the connector, so following here:
    https://github.com/ONLYOFFICE/onlyoffice-nextcloud/issues/262

  • Staff

    That error seems bizzare. I wonder if this happens with new installations. Our internal nextcloud+onlyoffice seems to be working just fine. Let me check.


  • @girish just fyi it's working fine for me on a new (5.1 now 5.1.4) install from 8 days ago, and on my other older install which has so far updated up to 5.1.3

  • Staff

    @ochoseis so did ensuring the onlyoffice-nextcloud connector being up-to-date help in your case?

  • App Dev

    This was happening on my machine this morning; clearing local data for the domain (top-level and therefore all apps) did resolve it.

  • Staff

    Yeah, I tried to reproduce this locally but this works if the app and connector is up to date.


  • For posterity, it started working again at some point at or before NextCloud v18.04 w/ the v4.1.4 OnlyOffice app. The OnlyOffice server was still at v5.5.1.


  • This issue starts to happen after I upgraded my Community Document Server to 0.1.8, ONLYOFFICE to 6.1.0, NextCloud version 20.0.2, with package version 4.8.1.

    I have tried to disable/re-enable the Community Document Server and ONLYOFFICE but no luck. I've also tried to restart the servers but no luck either.

    However, from my Android phone, running the latest version which is 3.14.0, my documents are loading fine without issues in ONLYOFFICE.

  • Staff

    @henry000 When you say issue happens, you mean exact same error as the screenshot in the initial post?


  • Hi @girish yes. When I opened a document or spreadsheet, that same dialog shows. After I click OK, the ONLYOFFICE progressbar just sits there forever.

    I think I know the issues now, will post a new reply to the thread below.


  • OK, for me the issues happens when I use Firefox. Other browsers and my Android phone are working perfectly fine.

    I'm on Windows 10 64-bit.

    Firefox is 83.0 has the issue, i.e. the dialog shows and documents hangs after I dismiss the dialog.

    Google Chrome, version 87.0.4280.66, works fine.

    Brave browser, version 1.17.73, works fine.

    I tried Firefox safe mode (i.e. without add-ons), it also did not work. I've uploaded the error messages in the Firefox debugging console, hope it might help.

    Firefox.PNG

  • Staff

    @henry000 Do you get these errors exactly when opening up the document or even before it? Some of the errors seems to be generic nextcloud errors. I wonder if some plugin is causing problems. FWIW, nextcloud+onlyoffice works in our install on firefox (my primary browser).


  • @girish said in Issue with NextCloud and OnlyOffice:

    FWIW, nextcloud+onlyoffice works in our install on firefox (my primary browser).

    Same here.


  • Hi @girish, the logs are at the time when the document is opened up. It's strange: As of this morning, I don't get the dialog anymore, now the dark gray "loading document" progressbar is hanging on my Firefox browser (Chrome still works fine).

    Anyways, I'll play with the Nextcloud plugins (mine are pretty standard plugins), and will report here if there's anything else.


  • Might not help if you have specific reasons for OnlyOffice but I spent some time comparing to Collabora and then uninstalled OnlyOffice.

    Initial attraction of only office was the UI seemed a little more likely to be familiar to users, although the latest Collabora with tabbed ribbon bards as an option nulled that difference.

    I noticed OnlyOffice seemed to have more restrictions on concurrent usage and higher costs if you did need to move to licensed.

    Then there's Collabora being a webified LibreOffice, so the UI consistency between those two is good for onboarding users to both with familiarity.

    Don't know if that helps but with Collabora as an option, I've not needed OnlyOffice, or any other Office for that matter, since.


  • @marcusquinn thanks, I was wondering why you'd opted for Collabora over OnlyOffice since I saw this section on your https://brandlight.org/ website:

    We saved over £15k a month with Brandlight apps & services.

    Switching from:

    Lastpass to Bitwarden
    Jira to GitLab
    Confluence to WikiJS
    Slack to Rocket.Chat
    Freshdesk to Freescout
    Amazon AWS to Hetzner
    Microsoft Azure to Contabo
    Gmail to Cloudron & Roundcube
    Google Drive to Nextcloud
    Google Apps to Collabora Online
    Microsoft Office to Libre Office
    Zoom to Kopano Meet
    Microsoft Dynamics to Odoo ERP & CRM
    Zapier to Integromat
    Codeless Platforms to n8n.io
    Power BI to Redash
    Trello to Wekan
    Monday to Restyaboard
    Survey Monkey to Lime Survey
    Campaign Monitor to Mautic & Elastic Email


  • I've previously found (and read) that Collabora is a lot slower when collaboratively editing because it does stuff on the server end that OnlyOffice does locally, but perhaps that is better these days?


  • @jdaviescoates I've found Collabora much better in terms of performance with recent versions (even though I am still dubious about their design choice when it comes to server / client processing). It's got also much less restrictions and prefer the default compatibility with odfs (the development seem to be faster these days too). I have stopped using OnlyOffice for quite a few month now and I don't regret it.