Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Bug with Mailing Lists that point to Aliases



  • I've got a couple of mailing lists that started bouncing with a response like Error: Nowhere to deliver mail to for domain: undefined (full sample below). I couldn't find a related question after a quick search so posting here.

    After some digging it seems like the issue is that I've got the mailing lists pointing to aliases instead of the original email addresses for the intended recipients. When I swap in the actual username-emails it works fine.

    This just stopped working recently. I'd intended to use the aliases in order to prevent the cloudron login username from leaking, but the error message below actually says the issue is delivering to username@undefined versus alias@undefined, which kind of defeats that purpose.

    To reproduce:

    1. Identify two users to test with: user_a, user_b.
    2. Create alias alias_a for user_a in a domain (e.g. example.com).
    3. Create mailing list my_mailing_list in same domain.
    4. Configure two recipients in mailing list: alias_a@example.com, user_b@example.com.
    5. Send a test message to my_mailing_list@example.com.
    6. Observe user_b receives the message, but alias_a / user_a does not, and sender receives an error referencing user_a instead of alias_a.

    Expected behavior:

    1. alias_a can receive the message.

    The error message:

    Hi. This is the Mailer program at my.example.com.
    
    I'm afraid I wasn't able to deliver your message
        "{{email_subject}}"
    to the following addresses.
    
    This is a permanent error; I've given up. Sorry it didn't work out.
    
    Intended Recipients: <{{user_a}}@undefined>
    Failure Reason: Error: Nowhere to deliver mail to for domain: undefined
    

  • Staff

    @ochoseis Thanks for the detailed post. I have to test this out and get back on why it's failing.



  • FWIW, the mailing lists stopped working right around the 5.2 release with some changes to both aliases and mailing lists:
    https://cloudron.io/blog/2020-06-01-cloudron-5.2.html


  • Staff

    @ochoseis Thanks, am able to reproduce it. Working on a fix


  • Staff

    @ochoseis This is fixed in 5.5. Should be out in a day or two.



  • @girish 👏 much appreciated... thanks for looking into it!


Log in to reply