Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Skip to content
  • Categories
  • Recent
  • Tags
  • Popular
  • Bookmarks
  • Search
Skins
  • Light
  • Brite
  • Cerulean
  • Cosmo
  • Flatly
  • Journal
  • Litera
  • Lumen
  • Lux
  • Materia
  • Minty
  • Morph
  • Pulse
  • Sandstone
  • Simplex
  • Sketchy
  • Spacelab
  • United
  • Yeti
  • Zephyr
  • Dark
  • Cyborg
  • Darkly
  • Quartz
  • Slate
  • Solar
  • Superhero
  • Vapor

  • Default (No Skin)
  • No Skin
Collapse
Brand Logo

Cloudron Forum

Offical apps | Community apps | Demo | Docs | Install
A

alwynispat

@alwynispat
Unfollow Follow
About
Posts
57
Topics
23
Shares
0
Groups
0
Followers
0
Following
0

Posts

Recent Best Controversial

  • What's coming in 8.2
    A alwynispat
    Announcements

    More backup retention options, even better, customizable, per app.


  • UPS support
    A alwynispat
    Feature Requests

    @BrutalBirdie my Cloudron is self hosted onprem. I have a UPS which powers my Synology, Cloudron, etc.
    My Synology acts as a UPS server which tells devices when they are on battery or if the UPS is almost flat.
    I would like Cloudron to be able to read that and prepare to gracefully shutdown.

    https://technet.fourit.nl/2022/09/22/shutdown-servers-from-synology/


  • Pixelfed 0.11.5 out now!
    A alwynispat
    Pixelfed

    https://github.com/pixelfed/pixelfed/releases/tag/v0.11.5


  • Migrate standalone Mastodon instance into/out of Cloudron
    A alwynispat
    Support migrate

    I’ve been crawling through the web and I can’t seem to find any guides on migrating a Mastodon instance into Cloudron. Is it possible?

    While we are at it, is it also possible to migrate the instance out of Cloudron?


  • What's coming in 8.2
    A alwynispat
    Announcements

    @girish I think what @odie would like to do is to restore from a backup which came from a different server.


  • UPS support
    A alwynispat
    Feature Requests

    Does Cloudron supports UPS shutdown notifications? Or do I have to manually install a tool in linux?


  • Trusted IP Address
    A alwynispat
    Support networking cloudflare trusted ips

    So I think I've found the solution.
    Modify the Proxy Host config > Advanced and paste the following:

    set_real_ip_from    03.21.244.0/22;
    set_real_ip_from    103.22.200.0/22;
    set_real_ip_from    103.31.4.0/22;
    set_real_ip_from    104.16.0.0/13;
    set_real_ip_from    104.24.0.0/14;
    set_real_ip_from    108.162.192.0/18;
    set_real_ip_from    131.0.72.0/22;
    set_real_ip_from    141.101.64.0/18;
    set_real_ip_from    162.158.0.0/15;
    set_real_ip_from    172.64.0.0/13;
    set_real_ip_from    173.245.48.0/20;
    set_real_ip_from    188.114.96.0/20;
    set_real_ip_from    190.93.240.0/20;
    set_real_ip_from    197.234.240.0/22;
    set_real_ip_from    198.41.128.0/17;
    
    #use any of the following two
    
    real_ip_header CF-Connecting-IP;
    #real_ip_header X-Forwarded-For;
    

    this will allow True Client IP Address to be passed to Cloudron.


  • Mastodon 4.1.0 Released!
    A alwynispat
    Mastodon

    I also recommend that the cleanup.sh to add the tootctl media remove --prune-profiles


  • Profile images doesnt load on S3
    A alwynispat
    Pixelfed

    @gh0stface so this is what I've setup;

    ## S3 Storage
    PF_ENABLE_CLOUD=true
    FILESYSTEM_DRIVER=local
    FILESYSTEM_CLOUD=s3
    PF_LOCAL_AVATAR_TO_CLOUD=true
    MEDIA_DELETE_LOCAL_AFTER_CLOUD=true
    AWS_ACCESS_KEY_ID=xxx
    AWS_SECRET_ACCESS_KEY=xxx
    AWS_DEFAULT_REGION=xxx
    AWS_BUCKET=mediapixelfedsg
    AWS_URL=https://media.pixelfed.sg
    AWS_ENDPOINT=https://xxx.backblazeb2.com
    #AWS_USE_PATH_STYLE_ENDPOINT=false
    

    and it works.


  • Mastodon 4.1.0 Released!
    A alwynispat
    Mastodon

    Mastodon has released 4.1.0 and it has a whole slew of fixes and features!

    https://github.com/mastodon/mastodon/releases/tag/v4.1.0

    Not rushing anyone but… 😬


  • Unable to cleanup Orphaned Media
    A alwynispat
    Mastodon

    @nebulon i've identified the issue and it was my S3 configuration.

    The endpoint and hostname should never have the bucket name.

    S3_ENDPOINT=https://s3.us-west-001.example.com
    S3_HOSTNAME=s3.us-west-001.example.com


  • How to install Elasticsearch on Mastodon?
    A alwynispat
    Mastodon

    @shanelord01 I've got mine working. It's only advisable to have it running from with in the same server otherwise you'll have to expose it to the internet.
    I'm hosting my ES in docker but its similar.

    Here's what I've done:

    1. Set your network.host and discovery.seed_hosts to 0.0.0.0, this is so that it'll be open to the internet
    2. Set your Port to something other than 9200, 9920 for example.
    3. Ensure that your firewall/port forwarding is setup.
    4. Configure your env.production
    ES_ENABLED=true
    ES_HOST=[ES IP Address]
    ES_PORT=9920
    
    1. I recommend a reboot of the app
    2. Run bin/tootctl search deploy in the app terminal

  • Docs for packaging apps
    A alwynispat
    Package development

    @girish is there a documentation where I can package my own apps?


  • Email - Designate external storage disk location for email, just like an app.
    A alwynispat
    Feature Requests

    looks like https://docs.cloudron.io/storage/#default-data-directory is now missing. I need to use another disk for mail storage.


  • By default N8N uses sqlite, does the Cloudron N8N use the built in PostgreSQL?
    A alwynispat
    N8N

    I’m currently hosting my N8N elsewhere and want to migrate it over to Cloudron. Does the N8N in Cloudron uses PostgreSQL? If it doesn’t, how do I set it up to use it? I think my data tables will grow with my workflows. thanks


  • Notifications via email
    A alwynispat
    Support

    @BrutalBirdie actually I didn’t get emails on backup failure, app update or reboot required. How do I enable those?


  • Issue with the API to change MemoryLimit
    A alwynispat
    Support api

    @girish said in Issue with the API to change MemoryLimit:

    --data-raw '{"memoryLimit":973078528}

    Thanks! this bit helped.


  • Dynamic IP Address
    A alwynispat
    Support

    So here’s the thing, my router has dual WAN.

    Recently, my primary has not been very stable and would failover to my secondary.
    I could see that Cloudron has picked up the new public IP Address but hasn’t updated the DNS records for the apps.

    Thanks, every 10 mins would be a lot better than 5 mins past the hour.


  • Error 500 on admin-ajax.php
    A alwynispat
    WordPress (Managed)

    Hi all,

    Not sure what is happening but admin-ajax.php is throwing error 500.

    [Mon Oct 16 01:53:46 2023] "POST /wp-admin/admin-ajax.php HTTP/2.0" 500 0 "https://[redacted]/wp-admin/upload.php?mode=grid" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/17.0 Safari/605.1.15"
    

    This happens when accessing Media Library in grid mode, no issues displaying images in list mode.

    I also noticed that my other plugin would fail, All-in-one WP Migration plugin would not be able to run export to backup. The same error would appear.

    What I've tried:

    • Disabling all plugins
    • Enabling default theme
    • Increased WP_MEMORY_LIMIT to 128M
    • Increased the App Memory Limit to 512M

    When I reboot the App or the Server, the site will not load and the logs will show:

    Healtheck error: Error: connect ECONNREFUSED 172.18.20.7:80
    

    Ideas?


  • Update to latest commits
    A alwynispat
    Pixelfed

    Can we have Pixelfed package updated to the latest commit to support the new landing pages and Filesystem_driver fixes?

  • Login

  • Don't have an account? Register

  • Login or register to search.
  • First post
    Last post
0
  • Categories
  • Recent
  • Tags
  • Popular
  • Bookmarks
  • Search