[1.26.3]
Update vaultwarden to 1.37.3
Full Changelog
Fix password change with newer web-vault by @BlackDex in #7634
Ignore reset-password auto-enroll when mail is disabled by @xhon-pelushi in #7585
Fix migration for MariaDB 12.2.2 by @Timshel in #7265
Add SSO_SIGNUPS_ALLOWED by @Timshel in #7272
Fix organization import failing with missing field groups by @tom27052006 in #7699
Add pm-32413-multi-client-password-management feature flag by @tom27052006 in #7677
Log IP/username on two-factor email-login credential failures by @crahn in #7654
Support admin reset 2fa by @Timshel in #7435
fix(security): revoke 2FA remember tokens when credentials or 2FA change by @BryanFRD in #7682
fix(security): rate limit prelogin and auth request endpoints by @BryanFRD in #7681
Hello @oauth2-tmp-cloudron-1784273754379-im6vnh
Please see https://forum.cloudron.io/topic/14812/vaultwarden-fails-to-start-after-update-db-migration-error-sso and apply the fix.
James, I found the solution. I forget to add {} before and after the variable, that makes my config.json error. Now, it's solved.
{
"signups_allowed": false,
"invitations_allowed": true,
}
Yes, it is set to false.
Maybe I was tricked because I had one Domain whitelisted. I don't remember if the "Register"-Link was always there. Would love to hide it.
It seems, that the disabled registration does work. Sorry for alerting...
By the way, Vaultwarden itself is fine with assets living elsewhere. You can use surfer to host for example logo files and then drop the link in the user.vaultwarden.scss.hbs file.
@jdaviescoates the comment in the package says there are some values that can only be set in env . But I cannot find what they are . AFAICT, it is safe to empty it out.
@necrevistonnezr my installation is quite old - that's correct. Thanks for checking in!
@girish , thank you for the doc's reference! Guess it might make sense to stress that during the installation, as well as an offer to increase KDF up to 2 mln (as per Bitwarden docs as well).