BookStack - knowledge management application



  • Just stumbled onto BookStack and it looks like it'd be a great wiki. I'd much prefer this over dealing with Dokuwiki.



  • Following up with a couple of links:



  • I've built a package where everything that I've checked out works as intended, except ldap. Not sure what I'm doing wrong or where the problem is, but if you watch their issue tracker, apparently some other people are having ldap issues as well. Either way, maybe someone can check it out and even find a solution for this, to debug you have to remove the comments in /app/data/.env - enable debug and ldap by removing the #:

    https://git.cloudron.io/msbt/bookstack-app

    Cheers



  • @nebulon or @girish is there someone who is best able to help out with specific issues like this (the ldap functionality of a package, e.g.)?



  • Great stuff 🙂 I will give this a shot later today



  • OK, I have the LDAP working but there is a bug where the port number is not parsed correctly. Still debugging.

    @msbt I forked the project to https://git.cloudron.io/cloudron/bookstack-app and given you permissions. Thanks!



  • ah that's why, thanks @girish! I haven't opened a ticket yet, maybe they need to fix something on their side. I'll do some more finetuning on the app when I get the chance, we could also use redis and some other features which aren't implemented yet.



  • @msbt Sorry, I forgot to leave a note yesterday but the issue is not in their code as such. The env var LDAP_SERVER gets overidden from the environment over the .env file (this is a variable that Cloudron injects...)



  • the redis password option just got added to the repo, I'll push the changes when a new release is out.



  • Looks like the repo here doesn't seem to allow login properly? Can't get admin@admin.com working, and LDAP isn't working either 😞



  • Hey @murgero! Yes, there is still an issue with ldap, @girish has a fix for that but I don't know how to implement that yet. The admin user should work though but I'll have another look this evening. My local repo also got updated to the latest version, if that's working with the admin account I'll push it to gitlab.



  • @murgero check the repo here https://git.cloudron.io/msbt/bookstack-app/ I've just did a clean reinstall and admin@admin.com and password as password are working, can you confirm that? Again, no LDAP support just yet, will have a talk with @girish about it soon



  • I'd like to give this subject a nudge!
    In my insignificant estimation it looks almost finished! 😎
    I would be very happy about the app.



  • Bad timing, I just pushed an update with the new manifestVersion, now LDAP is working properly. The downside: You still have to chose, either regular users or ldap, they won't mix.

    You can grab it from here: https://git.cloudron.io/msbt/bookstack-app/ and this is how to get it working:

    1) Login after installation using email 'admin@admin.com' and password of 'password'
    2) Go to Edit Profile and change the password
    3) Go to settings and make sure that registration is disabled and the Default user role after registration is set to Admin (at least until you've first logged in with an admin-account) and save the settings (even when you haven't changed anything)
    4) Remove the comment of AUTH_METHOD=ldap in /app/data/.env
    5) Login with your Cloudron account

    I will check out the thing with saving a setting which seems to be default, if that works we don't need a default admin account and steps 1, 2, 3 and 4 won't be necessary 😉



  • Fixed, now all you have to do is login after installation and adjust the settings for new users!

    Todo: redis support



  • @msbt Just an FYI I am getting a LOT of login errors after restarting the container after initial login:

    Jun 26 20:59:30 + [[ ! -f /app/data/.env ]]
    Jun 26 20:59:30 + [[ ! -d /run/sessions/ ]]
    Jun 26 20:59:30 + chmod -R 755 /app/data/uploads /app/data/storage
    Jun 26 20:59:30 + php artisan migrate --no-interaction --force
    [PDOException]
    Jun 26 20:58:28 SQLSTATE[HY000] [1045] Access denied for user 'REDACTED'@'f45baf31-
    Jun 26 20:58:28 somethingsomething.cloudron' (using password: YES)
    

    It has been sitting at repeating the above message for 30 minutes for me.



  • ok that doesn't seem right, I've removed migrations for now from startup (#php artisan migrate --no-interaction --force), gonna have to talk to @girish or @nebulon if something changed in the environment. if you grab the latest one, it should start up again. thanks for mentioning!



  • @msbt What do the migrations do here? If its for post-updates / install you can detect if you need to do that in bash by comparing files and such



  • Yeah that was in case a new version got out, I'll think of something better to handle that 😉



  • @msbt Just wanted to let you know, the fix you implemented did work. I am able to reconfigure, reboot, etc and it comes back up with no errors each time.


Log in to reply