Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


ONLYOFFICE + Nextcloud - Download Failed



  • Hello. I'm getting an error when trying to use the integration between ONLYOFFICE and Nextcloud. I've configured it as instructed by the documentation, but when I try to open a field I get an error saying "Download failed". This is what I find in the logs:

    Nextcloud logs

    Feb 07 19:13:46 172.18.0.1 - - [07/Feb/2020:19:13:45 +0000] "GET /apps/onlyoffice/download?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJmaWxlSWQiOjMxOTEzLCJ1encfile9hZCJ9.CWAmK-sthing HTTP/1.1" 503 5725 "-" "-"
    Feb 07 19:13:47 172.18.0.1 - USER [07/Feb/2020:19:13:47 +0000] "PROPFIND /remote.php/dav/files/user/ HTTP/1.1" 207 1078 "-" "Mozilla/5.0 (Macintosh) mirall/2.6.1stable (build 20191105) (Nextcloud)"
    

    ONLYOFFICE logs

    Feb 07 19:13:47 [2020-02-07T19:13:47.502] [ERROR] nodeJS - error downloadFile:url=https://cloud.hostname.com/apps/onlyoffice/download?doc=eyJ0eXAiOiJKV1QiLCJhbGciOiJIUzI1NiJ9.eyJmaWxlSWQiOjMxOTEzLCJ1bigencryptedstring9hZCJ9.CWAmK-FTxBaF4NISwQdaWIa02cbsbXKwqnvI7OXuzNU;attempt=3;code:null;connect:null;(id=2219794946)
    Feb 07 19:13:47 Error: Error response: statusCode:503 ;body:
    Feb 07 19:13:47 <!DOCTYPE html>
    Feb 07 19:13:47 <html>
    Feb 07 19:13:47 <head>
    Feb 07 19:13:47 <meta charset="utf-8" />
    Feb 07 19:13:47 <meta name="viewport" content="user-scalable=no, initial-scale=1, maximum-scale=1, minimum-scale=1, width=device-width, height=device-height" />
    Feb 07 19:13:47
    Feb 07 19:13:47 <title> Cloudron App Error </title>
    Feb 07 19:13:47
    Feb 07 19:13:47 <!-- Use static style as we can't include local stylesheets -->
    Feb 07 19:13:47 <style>
    Feb 07 19:13:47
    Feb 07 19:13:47 html {
    Feb 07 19:13:47 height: 100%;
    Feb 07 19:13:47 width: 100%;
    Feb 07 19:13:47 padding: 0;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 body {
    Feb 07 19:13:47 background-color: white;
    Feb 07 19:13:47 padding: 0;
    Feb 07 19:13:47 margin: 0;
    Feb 07 19:13:47 height: 100%;
    Feb 07 19:13:47 width: 100%;
    Feb 07 19:13:47 text-align: center;
    Feb 07 19:13:47 font-family: "Roboto","Helvetica Neue",Helvetica,Arial,sans-serif;
    Feb 07 19:13:47 font-size: 13px;
    Feb 07 19:13:47 line-height: 1.846;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 .content {
    Feb 07 19:13:47 display: flex;
    Feb 07 19:13:47 width: 100%;
    Feb 07 19:13:47 height: 100%;
    Feb 07 19:13:47 flex-direction: column;
    Feb 07 19:13:47 justify-content: center;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 footer {
    Feb 07 19:13:47 background-color: #EFEFEF;
    Feb 07 19:13:47 bottom: 0;
    Feb 07 19:13:47 width: 100%;
    Feb 07 19:13:47 color: #555;
    Feb 07 19:13:47 font-size: 12px;
    Feb 07 19:13:47 text-align: center;
    Feb 07 19:13:47 padding: 5px;
    Feb 07 19:13:47 z-index: 1000;
    Feb 07 19:13:47 position: fixed;
    Feb 07 19:13:47 opacity: .5;
    Feb 07 19:13:47 transition: all .25s;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 footer:hover {
    Feb 07 19:13:47 opacity: 1;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 a {
    Feb 07 19:13:47 color: #2196f3;
    Feb 07 19:13:47 text-decoration: none;
    Feb 07 19:13:47 background-color: transparent;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 a:hover {
    Feb 07 19:13:47 color: #0a6ebd;
    Feb 07 19:13:47 text-decoration: underline;
    Feb 07 19:13:47 }
    Feb 07 19:13:47
    Feb 07 19:13:47 </style>
    Feb 07 19:13:47
    Feb 07 19:13:47 </head>
    Feb 07 19:13:47
    Feb 07 19:13:47 <body>
    Feb 07 19:13:47
    Feb 07 19:13:47 <div class="content">
    Feb 07 19:13:47 <h1>&#128577;</h1>
    Feb 07 19:13:47 <h2>Something has gone wrong</h2>
    Feb 07 19:13:47 <p>This app is currently not responding. Try refreshing the page.</p>
    Feb 07 19:13:47 </div>
    Feb 07 19:13:47
    Feb 07 19:13:47 <footer>
    Feb 07 19:13:47 <span class="text-muted"><a href="https://cloudron.io" target="_blank">Cloudron</a></span>
    Feb 07 19:13:47 </footer>
    Feb 07 19:13:47
    Feb 07 19:13:47 </body>
    Feb 07 19:13:47 </html>
    Feb 07 19:13:47
    Feb 07 19:13:47 at Request._callback (/var/www/onlyoffice/documentserver/server/Common/sources/utils.js:257:18)
    Feb 07 19:13:47 at Request.self.callback (/var/www/onlyoffice/documentserver/server/Common/node_modules/request/request.js:185:22)
    Feb 07 19:13:47 at emitTwo (events.js:126:13)
    Feb 07 19:13:47 at Request.emit (events.js:214:7)
    Feb 07 19:13:47 at Request.<anonymous> (/var/www/onlyoffice/documentserver/server/Common/node_modules/request/request.js:1161:10)
    Feb 07 19:13:47 at emitOne (events.js:116:13)
    Feb 07 19:13:47 at Request.emit (events.js:211:7)
    Feb 07 19:13:47 at IncomingMessage.<anonymous> (/var/www/onlyoffice/documentserver/server/Common/node_modules/request/request.js:1083:12)
    Feb 07 19:13:47 at Object.onceWrapper (events.js:313:30)
    Feb 07 19:13:47 at emitNone (events.js:111:20)
    Feb 07 19:13:47 at IncomingMessage.emit (events.js:208:7)
    Feb 07 19:13:47 at endReadableNT (_stream_readable.js:1064:12)
    Feb 07 19:13:47 at _combinedTickCallback (internal/process/next_tick.js:139:11)
    Feb 07 19:13:47 at process._tickCallback (internal/process/next_tick.js:181:9)
    


  • Hmm... Some kind of progress...

    I found if I take the actual URL from the logs (ending in /apps/onlyoffice/download?doc=biglongstring) and paste it in my already authenticated browser (FF) at https://code.hostname.com/apps/onlyoffice/download?doc=biglongstring, it actually successfully downloads the file. It gives me an "Access Denied" error if I try in a new private window.

    I think that points to it having something to do with security headers or something effecting the server making, but I'm not sure.


  • Staff

    Could it be some extension on your browser?



  • Those are server logs for the applications, not browser. It appears that when the ONLYOFFICE server make it's request to Nextcloud, it gets a 503.

    Maybe the log that I'm seeing from Nextcloud is actually the webserver, not the Nextcloud application though. I'm not sure why it would show the 503 as well without any details.



  • Any other ideas on this? I tested in a completely different browser, just in case somehow it was a browser thing, but it doesn't appear to be.



  • There are actually two ONLYOFFICE apps in Nextcloud. There's the "Featured" connector named "ONLYOFFICE" and then another, non-featured, one called "Community Document Server".

    I'm using the featured one since it looks like it's the one linked in the documentation.



  • @iamthefij just checking but have you installed the ONLYOFFICE app in Cloudron too? Because you need that installed too if you're using the connector (it's what you need to connect to)

    The community document server should work on it's own, but as I understand it it doesn't have all features nor the same performance and scalability.



  • @jdaviescoates Yea, I've got it installed as well.

    That helps though in confirming that I've got the right Nextcloud app installed.

    The logs in my original post are coming from the respective Cloudron apps.

    The ONLYOFFICE Cloudron app is getting a 503 Cloudron App Error when trying to download the file from my Nextcloud server. I find this odd because I don't actually see a server error on the Nextcloud side. I see a GET returning 503, but no actual error or stack trace.


  • Staff

    @iamthefij Can you reproduce the setup in our demo - https://my.demo.cloudron.io (username and password is 'cloudron') ?


Log in to reply