Backup to NAS via SMB



  • Is there the possiblity to make a Backup to a Nas?
    The Nas is using either SMB or Ftp for access.
    It is the Nas System from a FritzBox.
    Thanks



  • Not IIRC. If you use a NAS that’s able to run Docker you may spin up a Minio instance and use that as backup target.



  • @smilebasti SMB/CIFS should work. See https://cloudron.io/documentation/backups/#sambacifs . Just mount it using the charset and then use the Filesystem backend on Cloudron.



  • @girish Nice. Stuff is happening on every aspect of this product 😃



  • Thanks. It worked 🙂
    I only had to add vers=1.0 because my NAS (FritzBox) only uses SMB 1.



  • As it finally finished Uploading i got this error. Any thoughts on how to solve this and may recognize the Permission earlier?

    Feb 13 19:44:23 box:tasks 1228: {"percent":26,"message":"Copying /backups/snapshot/app_0b0ea93e-1a87-4172-805c-c4171fd00c88.tar.gz to /backups/2020-02-13-110006-815/app_0b0ea93e-1a87-4172-805c-c4171fd00c88_2020-02-13-194423-405_v4.3.1.tar.gz (cloud.wieser.myhome-server.de)"}
    Feb 13 19:44:23 box:shell copy spawn: /bin/cp -al /backups/snapshot/app_0b0ea93e-1a87-4172-805c-c4171fd00c88.tar.gz /backups/2020-02-13-110006-815/app_0b0ea93e-1a87-4172-805c-c4171fd00c88_2020-02-13-194423-405_v4.3.1.tar.gz
    Feb 13 19:44:23 box:shell copy (stdout): /bin/cp:
    Feb 13 19:44:23 box:shell copy (stdout): cannot create hard link '/backups/2020-02-13-110006-815/app_0b0ea93e-1a87-4172-805c-c4171fd00c88_2020-02-13-194423-405_v4.3.1.tar.gz' to '/backups/snapshot/app_0b0ea93e-1a87-4172-805c-c4171fd00c88.tar.gz'
    Feb 13 19:44:23 box:shell copy (stdout): : Permission denied
    Feb 13 19:44:23 box:shell copy (stdout):
    Feb 13 19:44:23 box:shell copy code: 1, signal: null
    Feb 13 19:44:23 box:backups cloud.wieser.myhome-server.de Unable to backup { BoxError: copy exited with code 1 signal null
    


  • @smilebasti Possibly because the destination file system does not support hard links. In the Backup -> Configure, there is a checkbox to disable hard links.


Log in to reply