Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


SOLVED Cloudron install failed :(



  • Help! I just bought a brand new VPS server from Hetzner and then ran the 3 commands to install Cloudron, but it failed 😞

    root@ubuntu-8gb-hel1-1:~# wget https://cloudron.io/cloudron-setup
    --2020-04-03 15:15:50--  https://cloudron.io/cloudron-setup
    Resolving cloudron.io (cloudron.io)... 2600:9000:20a5:3c00:6:5fea:d280:93a1, 2600:9000:20a5:5e00:6:5fea:d280:93a1, 2600:9000:20a5:6600:6:5fea:d280:93a1, ...
    Connecting to cloudron.io (cloudron.io)|2600:9000:20a5:3c00:6:5fea:d280:93a1|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 9013 (8.8K) [binary/octet-stream]
    Saving to: ‘cloudron-setup’
    
    cloudron-setup                        100%[=======================================================================>]   8.80K  --.-KB/s    in 0s      
    
    2020-04-03 15:15:51 (99.1 MB/s) - ‘cloudron-setup’ saved [9013/9013]
    
    root@ubuntu-8gb-hel1-1:~# chmod +x ./cloudron-setup
    root@ubuntu-8gb-hel1-1:~# ./cloudron-setup --provider hetzner
    
    ##############################################
             Cloudron Setup (latest)
    ##############################################
    
     Follow setup logs in a second terminal with:
     $ tail -f /var/log/cloudron-setup.log
    
     Join us at https://forum.cloudron.io for any questions.
    
    => Installing software-properties-common
    => Ensure required apt sources
    => Updating apt and installing script dependencies
    => Checking version
    => Downloading version 5.1.0 ...
    => Installing base dependencies and downloading docker images (this takes some time) ...
    => Installing version 5.1.0 (this takes some time) ...
    Failed to install cloudron. See /var/log/cloudron-setup.log for details
    
    

  • Staff

    We are about to push a patch release for this, we got a couple of those today.
    Until the patch release is out please run apt-get install -y libcurl3-gnutls on the server and then re-run the cloudron-setup script



  • @nebulon thanks! That worked 🙂



  • Hi,
    I have error the same with upcloud :

    Follow setup logs in a second terminal with:
     $ tail -f /var/log/cloudron-setup.log
    
     Join us at https://forum.cloudron.io for any questions.
    
    => Installing software-properties-common
    => Ensure required apt sources
    => Updating apt and installing script dependencies
    => Checking version
    => Downloading version 5.1.1 ...
    => Installing base dependencies and downloading docker images (this takes some time) ...Init script failed. See /var/log/cloudron-setup.log for details
    root@ncloud-1cpu-1gb-sg-sin1:~#
    

    Please help me how to fix it.
    Thanks



  • @minhbaop What do you get running uname -a


  • Staff

    @minhbaop can you see the file at /var/log/cloudron-setup.log for more detail on the actual error?



  • Choose 1-4 [1]: 2
    /var/log~tup.log   [BM--] 42 L:[6069+20 6089/6090] *(501635/501642b)   10 [*][X]
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/dev-dep-update
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/release.sh
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/install.sh
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/update-authors.sh
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/gen-dev-ignores.js
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/changelog.js
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/maketest
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/publish-tag.js
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/dep-update
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/clean-old.sh
    node-v10.18.1-linux-x64/lib/node_modules/npm/scripts/docs-build.js
    node-v10.18.1-linux-x64/lib/node_modules/npm/README.md
    node-v10.18.1-linux-x64/lib/node_modules/npm/AUTHORS
    node-v10.18.1-linux-x64/LICENSE
    node-v10.18.1-linux-x64/bin/
    node-v10.18.1-linux-x64/bin/node
    
    gzip: stdin: unexpected end of file
    tar: Unexpected EOF in archive
    tar: Unexpected EOF in archive
    tar: Error is not recoverable: exiting now
    


  • @scooke said in Cloudron install failed 😞:

    @minhbaop What do you get running uname -a

    root@ubuntu-2vcpu-2gb-01:~# uname -a
    Linux ubuntu-2vcpu-2gb-01 4.15.0-46-generic #49-Ubuntu SMP Wed Feb 6 09:33:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    

  • Staff

    That seems to be a temporary failure about the nodejs release tarball not being fully downloaded. Can you just rerun the cloudron-setup script again?



  • @minhbaop @nebulon above is on the right track. I have had installation issues before because I was using a system using OpenVZ, not KVM. If you had OpenVZ then 4.15.0-46-generic would look more like 2.6.*-. I just thought I'd try this, you never know.


  • Staff

    actually it seems nodejs.org is having some issues currently, I also just had one download failing. So maybe retry in some time.


Log in to reply