Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.

Is it possible to host Cloudron on a Jelastic-powered cloud like Hidora?

  • Jelastic-powered clouds automatically scale your application vertically and horizontally based on the demand on resources. Works wonderfully with the dockerized private-instance of JitsiMeet that I run on it.

    If a Cloudron instance were hosted on a cloud like this, wouldn't it also help the Cloudron instance (and its active apps) automatically scale as per resource demand?

    Any thoughts?

  • This post is deleted!
  • App Dev

    I don't think you could run cloudron on a service like this (for those who don't know it, it's basically a Heroku clone).

    The problem is, the point of these services is to run a single app, and manage it. In a few words, too much magic to run more than very simple apps ^^

  • Staff

    Never heard of Hidora but if it's like Heroku then Cloudron cannot run on top of it.

    Does your jitsi instance actually scale horizontally or did you just manage to run it as a single Docker instance? I would be pleasantly surprised if it's the former. Scaling apps horizontally even for popular ones like WordPress is quite hard.

  • @mehdi said in Is it possible to host Cloudron on a Jelastic-powered cloud like Hidora?:

    The problem is, the point of these services is to run a single app, and manage it. In a few words, too much magic to run more than very simple apps ^^

    I meant to refer first to their "autoscaling" VPS offering where the CPU/RAM seem to scale automatically.

    The underlying tech that makes this possible is from Jelastic. This is how they differentiate themselves from AWS and Heroku:
    Hidora vs Heroku.png

  • The tech here is from Jelastic.

    @girish I have set JitsiMeet up to scale both vertically and horizontally; the search starts from tomorrow to find enough users to load it and actually make it scale!!! But I know people who have started with a similar small instance of Jisti and scaled it vertically - on demand - to 40+ users with great success. No need to start with a 4CPU/32GB RAM VPS to achieve this.

    And here is another business using the same underlying Jelastic tech to offer Jitsi and BigBlueButton meetings - of varying sizes - by the hour! It follows logically!

    There is a large overlap between the important Cloudron apps and their "easy-to-install, autoscaling" apps: Nextcloud, Gitlab, Mattermost, Jitsi, BigBlueButton, Redmine, WP, Ghost, etc

    From these two screenshots, its clear they clearly scale WP very well:
    Jelastic WP1.jpg Jelastic WP.png

  • @oj looks interesting, thanks. I think to run Cloudron on something like this though we'd need to find a provider who offers a Jelastic VPS with full Ubuntu that Cloudron could be installed on... Have you found any?

  • Staff

    I could be wrong but those look like PaaS templates (sort of like docker compose files or even the newer k8s helm templates). Installing things with lots of interconnected components only gets you 20% though. Someone has to understand what it installed, maintain this, have a backup system, periodically update this, apply patches etc. This is why I think they target devops and are selling infrastructure (as in, they are not selling "scalable wordpress").

    Of course, if they do all that, then it's a very good solution for hosting scalable apps. At least with Cloudron, our goal is not to install jitsi for 500 users or wordpress for million hits per day. Those products have to be priced very differently and have very different solution/architecture as well.

  • @jdaviescoates I currently use MirHosting and you can create Ubuntu VPS from their Jelastic platform, so I am (almost) sure you can do the same with your current Jelastic provider.

  • @alejandrolengua Do you mean you are using it for a Cloudron install?

  • @scooke Today I spent almost 4 hours trying to install Cloudron but got several error messages.
    If you want to see them you can check these Dropbox folder where I uploaded several screenshots

  • @alejandrolengua Hmmm. I guess it has Ubuntu 18 installed on that Jelastic?

  • Staff

    @alejandrolengua It seems that the installation process got stuck because some package required manual yes/no. Can you try this on a fresh Ubuntu 18.04:

    apt update
    apt upgrade

    Then install cloudron. I am guessing that one of the commands below will ask you a blocking yes/no question.

  • @alejandrolengua Which service are you using at Mirhosting?

    I'll be honest with you, that is one complicated looking Dashboard! I managed to figure out how to generate a plain old Ubuntu 18.04 environment, but on the free trial I can't have an IP4 address. So I will just continue and see how this goes.

    Well, I was trying to install Cloudron on both Mirhosting, and Ultime Hosting (france), but both do not provide IP4 addresses for the free trials. And I don't really want to add funds to these either, sorry. But I can say that it is definitively getting stuck at

    => Installing software-properties-common

    and tails tells me specifically:

    Configuration file '/etc/resolvconf/resolv.conf.d/base'
     ==> File on system created by you or by a script.
     ==> File also in package provided by package maintainer.
       What would you like to do about it ?  Your options are:
        Y or I  : install the package maintainer's version
        N or O  : keep your currently-installed version
          D     : show the differences between the versions
          Z     : start a shell to examine the situation
     The default action is to keep your current version.
    *** base (Y/I/N/O/D/Z) [default=N] ? Y

    It just hangs here. EDIT: I spoke too soon, after about 20 minutes it resumed.

    It seemed to fail again starting Docker.

    storage_driver=$(docker info | grep "Storage Driver" | sed 's/.*: //')
    Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

    I suspect that, according to the Dashboard, the environment I picked was Docker, and then I chose Ubuntu 18, whatever this jelastic is it already installed Docker in this service. Anyway, I ran systemctl start docker and systemctl daemon-reload, in one Terminal window, then reran the cloudron install script, and this time it resumed downloading all the various docker images. So, progress maybe?

    There was another fail, during the openjdk install. I wonder, I had to choose 8 "cloudlets" in order to get 1GB of ram for Cloudron, so I wonder if this is affecting the install. It doesn't sound like it is a physical instance, like a KVM VPS, so I suspect it is having trouble connecting everything and making it work. Maybe you should consider a plain old KVM? Good luck.
    (The setup before openjdk was nginx, which completed, but there was a warning :

    cat: /home/yellowtent/box/VERSION: No such file or directory
    ==> installer: Updating from  to 5.4.1 <==
    ==> installer: updating docker
    nginx version: nginx/1.18.0
    ==> installer: installing nginx 1.18
    WARNING: apt does not have a stable CLI interface. Use with caution in scripts.):

    The final errors:

    Setting up openjdk-11-jre-headless:amd64 (11.0.8+10-0ubuntu1~18.04.1) ...
    update-alternatives: using /usr/lib/jvm/java-11-openjdk-amd64/bin/rmid to provide /usr/bin/rmid (rmid) in auto mode
    update-alternatives: error: error creating symbolic link '/usr/share/man/man1/rmid.1.gz.dpkg-tmp': No such file or directory
    dpkg: error processing package openjdk-11-jre-headless:amd64 (--configure):
     installed openjdk-11-jre-headless:amd64 package post-installation script subprocess returned error exit status 2
    dpkg: dependency problems prevent configuration of default-jre-headless:
     default-jre-headless depends on openjdk-11-jre-headless; however:
      Package openjdk-11-jre-headless:amd64 is not configured yet.
    dpkg: error processing package default-jre-headless (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ca-certificates-java:
     ca-certificates-java depends on openjdk-11-jre-headless | java8-runtime-headless; however:
      Package openjdk-11-jre-headless:amd64 is not configured yet.
      Package java8-runtime-headless is not installed.
      Package default-jre-headless which provides java8-runtime-headless is not configured yet.
      Package openjdk-11-jre-headless:amd64 which provides java8-runtime-headless is not configured yet.
    dpkg: error processing package ca-certificates-java (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
    W: --force-yes is deprecated, use one of the options starting with --allow instead.
    E: Sub-process /usr/bin/dpkg returned an error code (1)