Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Try to go to App Store, but it just times out.



  • It just times out like this. I even restart the server. Nothing... This is ridiclous.

    • I even stopped a couple of my apps to see if has anything to do with memory or anything, but the same.

    09869d97-045b-4e2c-9584-f8696db1039b-image.png

    I'm guessing this has to do with it.

    2020-08-13T01:38:29.201Z ERROR Error getting IP getaddrinfo EAI_AGAIN api.cloudron.io api.cloudron.io:443 [ /home/yellowtent/box/src/sysinfo/generic.js:22:25 ] 
    stack: 
      """
        Error: getaddrinfo EAI_AGAIN api.cloudron.io api.cloudron.io:443
            at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:56:26)
      """
    message:  getaddrinfo EAI_AGAIN api.cloudron.io api.cloudron.io:443
    errno:    EAI_AGAIN
    code:     EAI_AGAIN
    syscall:  getaddrinfo
    hostname: api.cloudron.io
    host:     api.cloudron.io
    port:     443
    

  • Staff

    @austinsonger Indeed, it looks like maybe the DNS server is down? Can you check systemctl status unbound or check unbound status in the Services view? I would try to restart it and then see if host api.cloudron.io works on the server. It should resolve to an IP address.



  • ubuntu@ip-172-31-1-28:~$ systemctl status unbound
    ā— unbound.service - Unbound DNS Resolver
       Loaded: loaded (/etc/systemd/system/unbound.service; enabled; vendor preset: enabled)
       Active: active (running) since Wed 2020-08-12 21:04:49 UTC; 19h ago
     Main PID: 859 (unbound)
        Tasks: 1 (limit: 2342)
       CGroup: /system.slice/unbound.service
               ā””ā”€859 /usr/sbin/unbound -d
    
    Aug 12 21:04:49 ip-172-31-1-28 systemd[1]: Started Unbound DNS Resolver.
    Aug 12 21:04:49 ip-172-31-1-28 unbound[859]: [859:0] notice: init module 0: subnet
    Aug 12 21:04:49 ip-172-31-1-28 unbound[859]: [859:0] notice: init module 1: validator
    Aug 12 21:04:49 ip-172-31-1-28 unbound[859]: [859:0] notice: init module 2: iterator
    
    ubuntu@ip-172-31-1-28:~$ sudo systemctl restart unbound
    sudo: unable to resolve host ip-172-31-1-28: Resource temporarily unavailable
    
    ubuntu@ip-172-31-1-28:~$ host api.cloudtron.io
    ;; connection timed out; no servers could be reached
    

  • Staff

    @austinsonger It's api.cloudron.io (not cloudtron šŸ™‚ ).

    Can you also try these 3 commands:

    • host api.cloudron.io
    • host api.cloudron.io 8.8.8.8
    • host api.cloudron.io 127.0.0.1


  • @girish typo. .

    Results

    ubuntu@ip-172-31-1-28:~$ host api.cloudron.io
    ;; connection timed out; no servers could be reached
    ubuntu@ip-172-31-1-28:~$ ^C
    ubuntu@ip-172-31-1-28:~$ host api.cloudron.io 8.8.8.8
    ;; connection timed out; no servers could be reached
    ubuntu@ip-172-31-1-28:~$ host api.cloudron.io 127.0.0.1
    ;; connection timed out; no servers could be reached
    

  • Staff

    @austinsonger It seems outbound UDP port 53 itself is not working. Do you have some firewall or something else in place? The command host api.cloudron.io 8.8.8.8 directly contacts Google DNS servers via UDP port 53 but it's not working as seen from your output.



  • My outbound is completely open. I'm using AWS defaults. The only ports I have change is TCP ports related to the email.



  • There was a security update that happen on the dashboard and pretty much afterwards it stopped connecting to the Appstore. I'm going to create a outbound rule for UDP 53 to see if it forces it or something.


  • Staff

    @austinsonger Does ping 8.8.8.8 work?



  • @girish said in Try to go to App Store, but it just times out.:

    host api.cloudron.io 8.8.8.8

    It looks like creating a rule for outbound UDP 53 worked, but that's weird cause it was already setup for All ports outbound to be open.

    ubuntu@ip-172-31-1-28:~$ host api.cloudron.io 8.8.8.8
    Using domain server:
    Name: 8.8.8.8
    Address: 8.8.8.8#53
    Aliases: 
    
    api.cloudron.io has address ##.#.##.###
    ubuntu@ip-172-31-1-28:~$ ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
    

    when I do this ping it just sticks there and doesn't complete.



  • Should I try restart the server now? Just to see if that resolves it now.



  • This section just continues to load until it timesout as well.

    0a291850-236f-4895-9691-71d68bdb3900-image.png


  • Staff

    @austinsonger said in Try to go to App Store, but it just times out.:

    It looks like creating a rule for outbound UDP 53 worked, but that's weird cause it was already setup for All ports outbound to be open.

    Strange. The default as you said is to have All ports open. But if this is the case, can you also add HTTPS port there (tcp port 443) ? That will enable the appstore calls to work. In addition, for ping to work, you have to add ICMP port (this is a special protocol port like tcp/udp)



  • Yup. This makes no sense.

    9bafe7ee-807e-4e2a-ae5d-bbf0b94cf89e-image.png