Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Mayan EDMS


  • App Dev

    ah yes there was an error. I have fixed it in my dev box. It was an unpinned dependency, there are also issues with upgrading so it is still very much beta.

    I will publish the change shortly.

    @girish could you give me access to the cloudron hosted repo so I can make my commits direct?

    The latest push in my own public repo here has the fix. For info this is the change that pins the dependency to allow compiling. I have mentioned it in the upstream project and it should be fixed soon if it has not been already.


  • App Dev

    Ok I have been testing the upgrading which is tricky for me to figure out. Could use a fresh pair of eyes.

    This is how this image is working:

    1. Build image with deps
    2. pull the image version from the upstream repo based on the version number in the dockerfile
    3. run down and install everything
    4. Once complete the start.sh script in /app/pkg kicks off.
    5. After defining all the environment variables it will run this line of code:
    if [ ! -e "/app/data/init-completed" ]; then
      /app/data/venv/mayan-edms/bin/mayan-edms.py initialsetup
      echo "Setting up for initial install, this may take some time"
      touch /app/data/init-completed
    fi
    

    If there is a file called init-completed it will skip it.

    Now this is where the issue with upgrades come in I believe there is a command /app/data/venv/mayan-edms/bin/mayan-edms.py performupgrade.

    I have tried testing upgrades for a few hours but when it starts up all the services I simply get access denied issues.

    To replicate:

    • Clone my repo https://github.com/euanmcgregor/mayan-cloudron
    • Do an install to your cloudron - check that it works and login to check the version it should
    • Alter the dockerfile and change the variable from ENV MAYAN_VERSION=3.4.17 to ENV MAYAN_VERSION=3.5.1 which is the latest version
    • Perform a cloudron update

    Hope this make sense any help is appreciated.


  • Staff

    @ultraviolet You should have permissions now, thanks


  • App Dev

    @girish thanks

    I am going back to the drawing board for this one. So watch this space all....


  • App Dev

    I have come up with another way of installing to allow me to update the package. In the start.sh it will do it's initial install but that function of the app installs further items into /app/code/ which during an non debug session is RO. Is there any other way to allow this to install then seal the system to RO?

    An example during initialsetup:

      Applying tags.0006_documenttag... OK
      Applying tags.0007_auto_20170118_1758... OK
      Applying tags.0008_auto_20180917_0646... OK
      Applying user_management.0001_initial... OK
      Applying web_links.0001_initial... OK
      Applying web_links.0002_auto_20191210_0436... OK
      Applying web_links.0003_auto_20191211_0233... OK
    Installing package: Bootstrap (=3.4.1)... Downloading... Verifying... Extracting... Patching files... Traceback (most recent call last):
      File "/usr/lib/python3.7/pathlib.py", line 1258, in mkdir
        self._accessor.mkdir(self, mode)
    FileNotFoundError: [Errno 2] No such file or directory: '/app/code/venv/lib/python3.7/site-packages/mayan/apps/appearance/static/appearance/node_modules/bootstrap'
    
    <snip>
    
    
        self._accessor.mkdir(self, mode)
    OSError: [Errno 30] Read-only file system: '/app/code/venv/lib/python3.7/site-packages/mayan/apps/appearance/static/appearance/node_modules'
    

    Or if there is any other suggestions that I could try to get this installed?

    EDIT: I should add I am unable to do this during build as the app needs the database etc. to migrate and change the database



  • @ultraviolet you can make a note of all the errors and softlink them to someplace else for the build.


  • App Dev

    @robi good idea, never thought of that. Thanks


  • App Dev

    ok think we are good to go. I have pushed the code to my github the repo I will merge with the Cloudron hosted git soon.

    Just need some people to test install etc. and then will look at getting some tests into the package. It is still on version 3.4.17 as the latest version 3.5.1 has some issues in the celery queues which I will look at once that branch is a bit more stable.



  • When you need a DAU for testing, i'm in!



  • @daniel-goletz said in Mayan EDMS:

    DAU

    Daily Active User?


Log in to reply