Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.



  • I really need Resourcespace (https://forum.cloudron.io/topic/2036/resourcespace-digital-asset-management-dam) so I thought to give it a try to install it in the LAMP app (https://forum.cloudron.io/topic/2020/how-to-enable-ldap-support-in-lamp-app/9#)

    Install went very good (just copy-paste files from repo, config settings on first use).

    However I can't use it because it needs:

    php-ldap (very nice to have because of amount of users)
    FFmpeg - For creating previews of video and audio files
    Ghostscript - For creating previews of PDF files

    Furthermore:

    the install looks for php.ini in /etc/php/7.4/apache2/php.ini but the app php.ini is in app root and therefore it uses (or thinks it uses) the wrong values?

  • App Dev

    @imc67 /etc/php/7.4/apache2/php.ini and /app/data/php.ini are both the same file.

    As for the app - this will require a custom app to be created - for some thing simple like this I can have one built and ready for deployment by end of business today (CST/US). For such a simple transaction, I will charge only $50.

    Let me know if you would like this done.


  • @murgero

    About php.ini, I changed the values in the app-root version but Resourcespace is still noticing the “wrong” values, even after restarting the app.

    About your offer for packaging: thanks, this is a generous offer, though we have to wait for Cloudron 6 because of mounting external “disks” into the app to ingest videos and photos.

    If it’s really that simple (it was in LAMP) it’s time for me to make a study of packaging and finally do it myself after almost 2 years using Cloudron 😉

  • App Dev

    @imc67 Cloudron is awesome - I hope this new LAMP app comes quickly 🙂

  • Staff

    @imc67 I pushed a new LAMP package with ghostscript and LDAP support. Can you check?


  • @girish said in More packages needed for Resourcespace in LAMP:

    @imc67 I pushed a new LAMP package with ghostscript and LDAP support. Can you check?

    server config check of Resourcespace still says (also after new app and restore):

    ImageMagick Version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org OK
    FFmpeg Not installed
    Ghostscript Not installed
    EXIF extension OK
    ExifTool 10.80 OK
    php-zip OK

  • Staff

    @imc67 GS and ffmpeg are installed as ubuntu packages. Do you know what it's looking for? I even added these two to our future base image 3.0 since we have 3-4 apps requiring ghostscript anyway.


  • @girish said in More packages needed for Resourcespace in LAMP:

    @imc67 GS and ffmpeg are installed as ubuntu packages. Do you know what it's looking for? I even added these two to our future base image 3.0 since we have 3-4 apps requiring ghostscript anyway.

    This is what’s required:

    (https://www.resourcespace.com/knowledge-base/systemadmin/general_requirements)

    The following PHP extensions are required:
    php-gd
    php-dev
    php-mysql
    php-mbstring
    php-zip
    php-xml
    php-ldap
    php-intl
    php-curl
    In addition to the core programs the following applications are also required, for which the latest version is recommended:
    ImageMagick - For creating previews of images
    FFmpeg - For creating previews of video and audio files
    Ghostscript - For creating previews of PDF files
    ExifTool - For reading and writing Exif data from files

  • Staff

        apt install -y cron apache2-dev php7.4 php7.4-{bcmath,bz2,cgi,cli,common,curl,dba,dev,enchant,fpm,gd,gmp,imap,interbase,intl,json,ldap,mbstring,mysql,odbc,opcache,pgsql,phpdbg,pspell,readline,soap,sqlite3,sybase,tidy,xml,xmlrpc,xsl,zip} libapache2-mod-php7.4 php-{apcu,date,geoip,gettext,imagick,gnupg,mailparse,pear,redis,twig,uuid,validate,zmq} ghostscript libgs-dev ffmpeg && \
    

    is what we install. exiftool is there in the base image.