@ruihildt From https://wiki.js.org/get-started: Upgrading from 1.x to 2.0 will be quick and simple. You can safely use 1.x right now and upgrade later.