Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


server down: apps not restarting



  • It could also be you are storing backups locally. You can check in the backup tab yourcloudron.com/#/backups. If so, you will have to delete those somehow. The one line in your error message certainly points to the main culprit: no space left on device. You need to figure out what's using up the space.



  • @chymian-0 said in server down: apps not restarting:

    /tmp & /dev/pts are are pseudofilesystems and are not managed via fstab.
    they are too smale.

    And

    mkdir /tmp/pty465273103: no space left on device: unknown

    Have you checked if /tmp is mounted correctly and is writable? It should appear in df -h even if it is a pseudo-filesystem. Since you provided no informations it's hard to help you. Please note that support time is expensive and Cloudrons support only covers problems that are directly caused by cloudron. In addition, time spent on support cannot be used for development, so it is in our best interest to help you here.



  • @subven
    yes, sure 😉
    /tmp is not a tempfs, it's on root, and GBs free.
    it seems to have to do with cgroups and the space within the containers.
    when the system CTs run and one app, then its exhausted.
    I tried an older kernel, same.
    ??

    thx everybody for trying to help.

    I think thats a pure cloudron/system/cgroup pbl. as I haven't touched that system.
    and never came around that on my various other docker projects/server.


  • Staff

    @chymian-0 Sure, will be happy to take a look immediately. Are you able to run cloudron-support --enable-ssh and then send a mail to support@cloudron.io with your domain name/IP ?

    If that command doesn't work, put our ssh keys in your /root/.ssh/authorized_keys (https://cloudron.io/documentation/support/#ssh-keys)



  • @girish
    hey, thanks for help.
    I already did sent a mail to support with the info, a few hours ago. Didn't you receive that?
    it's from an ...r@gmx.net address.


  • Staff

    @chymian-0 Got it, will look into it shortly.


  • Staff

    @chymian-0 From what I can tell tell, there is inode exhaustion in the rootfs. If you do, df -i it tells you that you have run out of inodes. I think this is because this is run on top of btrfs. btrfs is notorious for this. We used to use btrfs on Cloudron 2-3 years ago and gave up because it's just some issue or the other like this. You can to do btrfs balance from outside the cloudron to free up some space, but I am not a btrfs expert.


  • Staff

    @chymian-0 The easiest fix is to just give the rootfs more space. Is this possible?

    Here's some discussion about it - https://lwn.net/Articles/724522/


  • Staff

    So, the issue here was that there nullmailer installed which was busy creating mails forever (lots and lots of files). Removing that software, fixed the problem.



  • kudos to @girish
    he found the real pbl. (out of i-nodes) within minutes.
    from there, we could nail down the cause, by following this:
    https://unix.stackexchange.com/questions/26598/how-can-i-increase-the-number-of-inodes-in-an-ext4-filesystem

    TL,DR:
    one cannot raise i-nodes after fs creation. normally, a tar from rootfs, reformat the rootfs, and restore would be necessary.
    but to find out, who is consuming all the inodes, one can do the following:

    try du -s --inodes * 2>/dev/null |sort -g then cd into the last dir in output and repeat.

    Full Disclosure: not all OS's support --inodes flag for du command (my Mac OS does not) but many Linux OS's do.

    one has to cd into the dir with the most i-nodes, recursively going down the tree and finally find the dir with the biggest i-node consumption.

    in this case, as girish had mentioned, it was caused by not right configured nullmailer, writing tons of error-msg to /var/spool/nullmailer/failed useing 4.4M i-nodes…
    deleting that dir eased the situation ad hoc.
    rebooting the server and restart all failed apps (GUI & CLI) fixed it.

    thanks for all your help


Log in to reply