Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Ghost issue with subscriber email and mail configuration



  • Hey guys, I recently installed Cloudron 1-click through Digital Ocean and started running my Ghost CMS app. The whole process was fairly quick and didn't take much time.

    The problem for me is emails and signup, I was able to access my Ghost Admin, my blog and everything looks fine but new members are not able to signup 😞 It first said "Please enter a valid email" which I corrected by following their email docs. Now that is fixed, now it's showing "please check your inbox for confirmation email" at signup but no messages are being sent!

    To fix this I followed their setup instructions for Mailgun and have updated that in my Admin settings and in config json file. After the changes are made, we need to restart the app for config changes to take place, when I restart Cloudron again puts in it's own config for email (the default). I even tried to add my Mailgun credentials in Outbound email settings of Cloudron, issue still remains!!

    Shouldn't we have control over what config is being used instead of being forced into defaults?

    This sounds similar problem to this - Can we use Cloudron smtp for ghost email config



  • I note this page in the Ghost docs says:

    Ghost Members and newsletters (beta) contains the ability to deliver posts natively by email. You cannot deliver bulk emails to many recipients via SMTP, so a bulk-mail provider is required in order to achieve this.

    And:

    Why can't I just use SMTP mail config to send email newsletters with Ghost?

    Sending a bulk email to many recipients using basic SMTP will result in your IP address being instantly blacklisted and marked as spam by all mail providers. You should never, ever send bulk mail using basic SMTP, which is why Ghost does not support it.

    More info here, and here, and here, and here.

    So perhaps that is why this isn't working?


  • Staff

    Apps on Cloudron are setup to use the Cloudron mail infra to send out emails. On every app restart we will overwrite the mail sending settings. Ideally we could disable the mail portion of the settings in the Ghost UI to avoid this confusion.

    So in your case the root issue lies somewhere in the Cloudron mail sending itself. You can setup Mailgun as the outbound email relay through the Cloudron dashboard. This would then also fix mail delivery issues for all other apps.


  • Staff

    As @nebulon said, put the mailgun credentials in cloudrons mail server instead of inside ghost. This setting is in email -> outbound.



  • @girish yup did this too! Email -> Outbound -> input my Mailgun settings -> Saved.

    Still not working. I'm able to send test email but the actual signup form emails are unsent.


  • Staff

    @iamdinakar let me try this in my local cloudron now.


  • Staff

    @iamdinakar OK, I go this working (cc @atrilahiji as well)

    The "tricky" part is that Ghost seems to want to send emails as noreply@domain.com. It also wants send newsletter by default as noreply@ghost.domain.com (i.e the app's domain).

    I will show how to setup Ghost to setup an email address newsletter@domain.com instead.

    1. We have to create a mailbox in your domain dedicated for this newsletter. If your domain is hosted on Cloudron, you go to mailboxes and create one. I created newsletter@cloudron.space. You can skip this if your email is hosted elsewhere (and you have to create the mailbox in your mail provider instead).

      47b8b193-0cac-4554-a500-c400869b85a8-image.png

    2. Recall that I said that Ghost wants to send emails with multiple email addresses noreply and newsletter. For this to work, we have to enable Masquerading in Cloudron's mail server.

      48b8a532-b5de-427c-a950-03ff28390b2a-image.png

    3. Next, we configure the email address for the Ghost app to be newsletter@domain.com.

      7e6008f5-2fee-4cb6-a64d-dfa7642a9dae-image.png

    4. Next, go to Ghost and enable members (under Labs)

      f23ba54d-fbbd-4398-9b82-ab4be909e632-image.png

    5. Change the Support and Newsletter email addresses in the members UI to the newsletter@domain.com.

      e2c1dbd7-1568-45ec-a468-74aef218065e-image.png

    6. You have to confirm the email Ghost sent to newsletter@domain.com

      95ff4fa0-40cb-4ecf-a971-96c70b818ca5-image.png

    Testing

    • Go the blog and click Subscribe button in the top nav bar. It pops up a dialog.

      028b1833-0477-4273-a35b-7f1daaf6c346-image.png

    • Click subscribe
      69928829-34ff-41ab-ac84-66785b09886a-image.png

    • Check inbox

      08fe84fe-ae74-41ca-8e32-1720e08f9298-image.png


  • App Dev

    @girish I haven't noticed issues with login emails or newsletter emails without any additional setup. I'll double check everything.



  • Thought I'd test again too after seeing this post.

    I've also not had an issue, just standard Ghost + Casper theme + Mailgun API entered in the Lab settings.

    marcusquinn.com if anyone wanted to subscribe. Won't be posting for a while though, time is limited with family care needs for a while.



  • I've got this issue too, and can't (yet) do the proposed solution @girish has posted because I've only got outgoing mail set-up for the domain I wanted Ghost to be on 😕

    I've got Mailgun API in Ghost Labs section, and Outgoing Mail for the Domain the Ghost app is installed on on Cloudron has Mailgun SMTP details added too.

    But no emails arrive...



  • @marcusquinn said in Ghost issue with subscriber email and mail configuration:

    I've also not had an issue, just standard Ghost + Casper theme + Mailgun API entered in the Lab settings.

    I assume Ghost installed on Cloudron?

    Have you got outgoing emails set to Mailgun on Cloudron?

    And do you have incoming emails set-up for marcusquinn.com set-up on Cloudron too?

    I assume you've got all the DNS records from Mailgun set-up?

    @marcusquinn said in Ghost issue with subscriber email and mail configuration:

    marcusquinn.com if anyone wanted to subscribe. Won't be posting for a while though, time is limited with family care needs for a while.

    Can confirm that your emails arrive.

    Although annoyingly can't close the confirmation banner at the top once I confirmed:

    confirmation_banner.png



  • @jdaviescoates Think that's a bug with the theme, a refresh of click should clear, but yeah, all on Cloudron and standard setup in Ghost and standard Cloudron SMTP setup, not using Mailgun for that.



  • @marcusquinn ok thanks.

    Hmz, so I wonder why it's not working for myself and @iamdinakar 😕


  • Staff

    @jdaviescoates So, the issue is you do not get emails? Where is your incoming mail server?



  • @girish I think the issue is the the mails are not sent.

    The incoming mail sever for the domain is Google Apps/ G Suite/ whatever the hell it is called these days


  • Staff

    To check things on order:

    • Ghost is configured to send mail via Cloudron. Cloudron is configured to send mail via Mailgun.

    • Now, check is Cloudron can send mail. There is a test mail button in the Email view for each domain.

    • Then, send a test mail from Ghost. You can check in Cloudron Mail Server logs, if Ghost even tries to send mail via Cloudron.

    • Finally, if all works, it probably ended up in Spam. If it's not even in Spam, it's probably because google blackholed it. I have seen this happen sometimes when email gets accepted by Google but it just "disappears"/ not seen by user at all.



  • @girish said in Ghost issue with subscriber email and mail configuration:

    Ghost is configured to send mail via Cloudron.

    I'm unclear about this. Ghost requires that you use Mailgun to use it's Membership features. And @marcusquinn says he has it working be putting his Mailgun API into his Cloudron-hosted Ghost



  • @girish said in Ghost issue with subscriber email and mail configuration:

    Now, check is Cloudron can send mail. There is a test mail button in the Email view for each domain.

    Test mail arrives fine.



  • @girish said in Ghost issue with subscriber email and mail configuration:

    Then, send a test mail from Ghost. You can check in Cloudron Mail Server logs, if Ghost even tries to send mail via Cloudron.

    Can't see anything in the logs. But then I've got my Mailgun API in the Ghost Members setting in the Lab section of settings, because that is what you have to use.

    /me goes to Mailgun to see what what I can see there...


  • Staff

    @jdaviescoates I now realize maybe we are talking of different things. One is membership setup for which I posted the instructions in https://forum.cloudron.io/post/15371 . This did not require any mailgun related things. I guess you are talking about the newsletter which is maybe configured somewhere else (https://ghost.org/faq/mailgun-newsletters/)