Excellent! Thank you very much @joseph (and also @fbartels)! I was able to alter the mysql dump file in the appsdata directory on the server and restarted the restore. The app started and I was able to fix all other database bugs in the dump directly in the apps database which then was up and running. Now the app has been restored on the new server and everything is working again. Thanks for the support and especially the note about the /home/yellowtent/appsdata/<appid>/mysqldump location.
NCKNE
Posts
-
Restore HumHum App on different server -
Restore HumHum App on different server@nckne we don't even have a table named
translator_cache. Could it be this comes from some module/plugin? Maybe you disabled it and afterwards may be migrations are not run
? Most likely it is because 8.4 MySQL is not accepting something that previous MySQL accepted.Yes - the table comes from the "translator" module (plugin).
I made the mistake to restore a previous backup on the primary host of the app and now it does not start there with the same error during the restore again. So I have no running instance of the app anymore now
. I figure getting this up and running again now involves extracting the mysql database from the backup file (which needs to be decrypted first) altering the table definitions and repackaging it to a new backup file...Or is there any another way? Does the restore process drop the database/tables before they are imported again? If not, is there a way to set the app as "restored" manually by cli / editing files on the box? I cannot access the MySQL credentials for the app without the app starting so I cannot connect to the apps database for further evaluations...
Or can the mysql version be downgraded to the previously used version? I migrated all other apps to another server so this would not cause any regressions for other apps and might be the easiest way.
-
Restore HumHum App on different serverThe mysql logs surfaced the problem during the restore:
Aug 07 14:22:38 [POST] /databases Aug 07 14:22:38 add: adding database e24ab7ec3e6f531b Aug 07 14:22:38 [POST] /databases/e24ab7ec3e6f531b/clear Aug 07 14:22:38 clear: database e24ab7ec3e6f531b Aug 07 14:23:07 [POST] /databases/e24ab7ec3e6f531b/restore Aug 07 14:23:07 restore: restoring database e24ab7ec3e6f531b Aug 07 14:23:07 pipeRequestToProcess: stderr: ERROR 6125 (HY000) at line 2047: Failed to add the foreign key constraint. Missing unique key for constraint 'fk-translator_history-translator_cache' in the referenced table 'translator_cache' Aug 07 14:23:07 pipeRequestToProcess: process exited with code 1 Aug 07 14:23:07 backupPrefix: Failed to restore database e24ab7ec3e6f531b Error: process exited with code 1 Aug 07 14:23:07 at pipeRequestToProcess (file:///app/code/node_modules/@cloudron/pipework/index.js:127:15) Aug 07 14:23:07 at process.processTicksAndRejections (node:internal/process/task_queues:105:5) Aug 07 14:23:07 at async restore (file:///app/code/service.js:255:9)Interesting that this does not prevent the app from starting on the current server.
I will check the HumHub app for ways to clear this.
If not successful, I suppose I need to check how extract the mysql dump from the backup file, repackage it and try to import it again.
-
Image caching in community app store?I published an app to the community app store and changed the app icon afterwards (new URL in manifest and CloudronVersions.json) and published a new version of the package. However, the icon in the community app store seems to be cached for the app and does not update. Is it possible to change the image of an already published app?
-
Restore HumHum App on different serverThe MySQL shell for the app is only available when the app is started. Die to the unsuccessful restore, it cannot be started. I guess a complete manual backup of all files and folders (/app/data) and a manual MySQL dump and restore might be possible, but maybe there is an easier way to fix this? I will check the MySQL logs tomorrow. I doubt it is an OOM problem.as the limits are set very high and the server has plenty of resources available.
The MySQL shell for the app is only available when the app is started. Due to the unsuccessful restore, it cannot be started. I guess a complete manual backup of all files and folders (/app/data) and a manual MySQL dump and restore might be possible, but maybe there is an easier way to fix this? I will check the MySQL logs tomorrow. I doubt it is an OOM problem as the limits are set very high and the server has plenty of resources available.
-
π« School Management Platform (German): SchulDialogPlusOnly relevant for German speaking people, therefore in German:
Die Plattform SchulDialogPlus fΓΌr Schulen ist nun als Community App in Cloudron verfΓΌgbar. Infos zu den Funktionen gibt es auf der Webseite www.schuldialogplus.de
Die Anmeldung sowie der E-Mailversand ΓΌber Cloudron sind integriert.
-
Restore HumHum App on different server -
Restore HumHum App on different serverI need to move an app (HumHub) from one server to another. The domain is registered on both servers and I installed the HumHub Package (same Version 1.9.4) on the new server with the same domain. Both Servers are running latest Cloudron 9.2. When restoring the backup I get the errors in the uploaded log file: https://download.plaxon.consulting/HumHubBackupImport.log
The memory settings for mysql and for the app itself are set to an insane high value for this small app, so this should not be the problem.
Could there be an issue in the restore process itself?
-
GitLab not starting. -
GitLab not starting.Fixed by entering recovery mode of the app and setting
mem_gb=$(( $(cat /sys/fs/cgroup/memory.max) / 1073741824 ))to
# mem_gb=$(( $(cat /sys/fs/cgroup/memory.max) / 1073741824 )) mem_gb=10in /home/git/start.sh
and running start.sh manually (still in recovery mode).
Seems like a bug though that should be fixed in the package.
-
GitLab not starting.Latest version of the GitLab container (but also previous version tested) does not start anymore. Logs see logs at the end. I assume the lines
/home/git/start.sh: line 216: / 1073741824 : syntax error: operand expected (error token is "/ 1073741824 ") Jul 09 13:12:59 /home/git/start.sh: line 217: mem_gb: unbound variablein the container log might be the root cause.
Can anyone help getting GitLab running again?
2026-07-09T11:08:17.080Z box:apptask startApp: starting container 2026-07-09T11:08:17.443Z box:tasks updating task 17001 with: {"percent":90,"message":"Configuring reverse proxy"} 2026-07-09T11:08:17.447Z box:tasks updating task 17001 with: {"percent":100,"message":"Done"} 2026-07-09T11:08:17.457Z box:tasks setCompleted - 17001: {"result":null,"error":null,"percent":100} 2026-07-09T11:08:17.457Z box:tasks updating task 17001 with: {"completed":true,"result":null,"error":null,"percent":100} 2026-07-09T11:08:17.462Z Exiting with code 0 2026-07-09T11:08:17.462Z box:taskworker Task took 210.669 seconds 2026-07-09T11:08:17Z ==> Copying schema file 2026-07-09T11:08:17Z ==> Fixing secrets 2026-07-09T11:08:17Z ==> Initializing gitlab shell 2026-07-09T11:08:17Z ==> Reusing existing host keys 2026-07-09T11:08:17Z ==> Setting up tmp 2026-07-09T11:08:18Z ==> Fixing permissions 2026-07-09T11:08:19Z ==> Creating pg_trgm extension 2026-07-09T11:08:19Z ==> Upgrading existing db 2026-07-09T11:08:19Z NOTICE: extension "pg_trgm" already exists, skipping 2026-07-09T11:08:20.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:08:24Z [0m[33mBundler will use `/tmp/bundler20260709-172-26om0y172' as your home directory temporarily. 2026-07-09T11:08:24Z [33m`/home/git` is not writable. 2026-07-09T11:08:30.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:08:40.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:08:42Z 2026-07-09T11:08:42Z 2026-07-09T11:08:42Z 2026-07-09T11:08:42Z 2026-07-09T11:08:42Z [0m 2026-07-09T11:08:42Z [0m 2026-07-09T11:08:42Z [0m[31m 2026-07-09T11:08:42Z [31m 2026-07-09T11:08:42Z ****************************************************************************** 2026-07-09T11:08:42Z ****************************************************************************** 2026-07-09T11:08:42Z ****************************************************************************** 2026-07-09T11:08:42Z ****************************************************************************** 2026-07-09T11:08:42Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:08:42Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:08:42Z You are using PostgreSQL 16.11 for the ci database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:08:42Z You are using PostgreSQL 16.11 for the main database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:08:42Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:08:42Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:08:42Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:08:42Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:08:42Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:08:42Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:08:42Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:08:42Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:08:42Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:08:42Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:08:42Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:08:42Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:08:50.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:00.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:01Z main: == [advisory_lock_connection] object_id: 56440, pg_backend_pid: 419 2026-07-09T11:09:02Z main: == [advisory_lock_connection] object_id: 56440, pg_backend_pid: 419 2026-07-09T11:09:07Z ==> Installing gitlab shell 2026-07-09T11:09:07Z ==> Synchronizing ssh keys 2026-07-09T11:09:07Z chmod 700 /home/git/.ssh: OK 2026-07-09T11:09:07Z mkdir -p /home/git/.ssh: OK 2026-07-09T11:09:10.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:12Z [0m[33mBundler will use `/tmp/bundler20260709-277-4fesnx277' as your home directory temporarily. 2026-07-09T11:09:12Z [33m`/home/git` is not writable. 2026-07-09T11:09:20.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:30.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:31Z 2026-07-09T11:09:31Z 2026-07-09T11:09:31Z 2026-07-09T11:09:31Z 2026-07-09T11:09:31Z [0m 2026-07-09T11:09:31Z [0m 2026-07-09T11:09:31Z [0m[31m 2026-07-09T11:09:31Z [31m 2026-07-09T11:09:31Z ****************************************************************************** 2026-07-09T11:09:31Z ****************************************************************************** 2026-07-09T11:09:31Z ****************************************************************************** 2026-07-09T11:09:31Z ****************************************************************************** 2026-07-09T11:09:31Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:09:31Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:09:31Z You are using PostgreSQL 16.11 for the ci database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:09:31Z You are using PostgreSQL 16.11 for the main database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:09:31Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:09:31Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:09:31Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:09:31Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:09:31Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:09:31Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:09:31Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:09:31Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:09:31Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:09:31Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:09:31Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:09:31Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:09:40.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:49Z [34mDo you want to continue (yes/no)? [0m 2026-07-09T11:09:49Z /home/git/start.sh: line 216: / 1073741824 : syntax error: operand expected (error token is "/ 1073741824 ") 2026-07-09T11:09:49Z /home/git/start.sh: line 217: mem_gb: unbound variable 2026-07-09T11:09:49Z This task will now rebuild the authorized_keys file. 2026-07-09T11:09:49Z You will lose any data stored in the authorized_keys file. 2026-07-09T11:09:49Z cat: /sys/fs/cgroup/memory.max: No such file or directory 2026-07-09T11:09:51.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:09:51Z ==> Copying schema file 2026-07-09T11:09:51Z ==> Fixing secrets 2026-07-09T11:09:51Z ==> Initializing gitlab shell 2026-07-09T11:09:51Z ==> Reusing existing host keys 2026-07-09T11:09:51Z ==> Setting up tmp 2026-07-09T11:09:52Z ==> Creating pg_trgm extension 2026-07-09T11:09:52Z ==> Fixing permissions 2026-07-09T11:09:52Z ==> Upgrading existing db 2026-07-09T11:09:52Z NOTICE: extension "pg_trgm" already exists, skipping 2026-07-09T11:09:57Z [0m[33mBundler will use `/tmp/bundler20260709-172-139zlf172' as your home directory temporarily. 2026-07-09T11:09:57Z [33m`/home/git` is not writable. 2026-07-09T11:10:00.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:10:10.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:10:16Z 2026-07-09T11:10:16Z 2026-07-09T11:10:16Z [0m 2026-07-09T11:10:16Z [0m[31m 2026-07-09T11:10:16Z ****************************************************************************** 2026-07-09T11:10:16Z ****************************************************************************** 26-07-09T11:10:16Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:10:16Z You are using PostgreSQL 16.11 for the main database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:10:16Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:10:16Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:10:16Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:10:16Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:10:16Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:10:16Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:10:17Z 2026-07-09T11:10:17Z 2026-07-09T11:10:17Z [0m 2026-07-09T11:10:17Z [31m 2026-07-09T11:10:17Z ****************************************************************************** 2026-07-09T11:10:17Z ****************************************************************************** 2026-07-09T11:10:17Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:10:17Z You are using PostgreSQL 16.11 for the ci database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:10:17Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:10:17Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:10:17Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:10:17Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:10:17Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:10:17Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:10:20.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:10:30.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:10:36Z main: == [advisory_lock_connection] object_id: 56440, pg_backend_pid: 448 2026-07-09T11:10:36Z main: == [advisory_lock_connection] object_id: 56440, pg_backend_pid: 448 2026-07-09T11:10:40.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:10:42Z ==> Installing gitlab shell 2026-07-09T11:10:42Z ==> Synchronizing ssh keys 2026-07-09T11:10:42Z chmod 700 /home/git/.ssh: OK 2026-07-09T11:10:42Z mkdir -p /home/git/.ssh: OK 2026-07-09T11:10:47Z [0m[33mBundler will use `/tmp/bundler20260709-278-im9yai278' as your home directory temporarily. 2026-07-09T11:10:47Z [33m`/home/git` is not writable. 2026-07-09T11:10:50.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:00.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:06Z 2026-07-09T11:11:06Z 2026-07-09T11:11:06Z 2026-07-09T11:11:06Z 2026-07-09T11:11:06Z [0m 2026-07-09T11:11:06Z [0m 2026-07-09T11:11:06Z [0m[31m 2026-07-09T11:11:06Z [31m 2026-07-09T11:11:06Z ****************************************************************************** 2026-07-09T11:11:06Z ****************************************************************************** 2026-07-09T11:11:06Z ****************************************************************************** 2026-07-09T11:11:06Z ****************************************************************************** 2026-07-09T11:11:06Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:11:06Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:11:06Z You are using PostgreSQL 16.11 for the ci database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:11:06Z You are using PostgreSQL 16.11 for the main database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:11:06Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:11:06Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:11:06Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:11:06Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:11:06Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:11:06Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:11:06Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:11:06Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:11:06Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:11:06Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:11:06Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:11:06Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:11:10.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:20.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:24Z [34mDo you want to continue (yes/no)? [0m 2026-07-09T11:11:24Z /home/git/start.sh: line 216: / 1073741824 : syntax error: operand expected (error token is "/ 1073741824 ") 2026-07-09T11:11:24Z /home/git/start.sh: line 217: mem_gb: unbound variable 2026-07-09T11:11:24Z This task will now rebuild the authorized_keys file. 2026-07-09T11:11:24Z You will lose any data stored in the authorized_keys file. 2026-07-09T11:11:24Z cat: /sys/fs/cgroup/memory.max: No such file or directory 2026-07-09T11:11:26Z ==> Copying schema file 2026-07-09T11:11:26Z ==> Fixing secrets 2026-07-09T11:11:26Z ==> Initializing gitlab shell 2026-07-09T11:11:26Z ==> Reusing existing host keys 2026-07-09T11:11:26Z ==> Setting up tmp 2026-07-09T11:11:27Z ==> Creating pg_trgm extension 2026-07-09T11:11:27Z ==> Fixing permissions 2026-07-09T11:11:27Z ==> Upgrading existing db 2026-07-09T11:11:27Z NOTICE: extension "pg_trgm" already exists, skipping 2026-07-09T11:11:30.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:32Z [0m[33mBundler will use `/tmp/bundler20260709-171-9wygvk171' as your home directory temporarily. 2026-07-09T11:11:32Z [33m`/home/git` is not writable. 2026-07-09T11:11:40.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:50.000Z => Healthcheck error: Error: connect ECONNREFUSED 172.18.16.166:80 2026-07-09T11:11:50Z 13:M 09 Jul 2026 11:11:50.092 * 10 changes in 300 seconds. Saving... 2026-07-09T11:11:50Z 13:M 09 Jul 2026 11:11:50.096 * Background saving started by pid 40 2026-07-09T11:11:50Z 13:M 09 Jul 2026 11:11:50.198 * Background saving terminated with success 2026-07-09T11:11:50Z 40:C 09 Jul 2026 11:11:50.136 * DB saved on disk 2026-07-09T11:11:50Z 40:C 09 Jul 2026 11:11:50.137 * Fork CoW for RDB: current 0 MB, peak 0 MB, average 0 MB 2026-07-09T11:11:51Z 2026-07-09T11:11:51Z 2026-07-09T11:11:51Z 2026-07-09T11:11:51Z 2026-07-09T11:11:51Z [0m 2026-07-09T11:11:51Z [0m 2026-07-09T11:11:51Z [0m[31m 2026-07-09T11:11:51Z [31m 2026-07-09T11:11:51Z ****************************************************************************** 2026-07-09T11:11:51Z ****************************************************************************** 2026-07-09T11:11:51Z ****************************************************************************** 2026-07-09T11:11:51Z ****************************************************************************** 2026-07-09T11:11:51Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:11:51Z Please upgrade your environment to a supported PostgreSQL version. See 2026-07-09T11:11:51Z You are using PostgreSQL 16.11 for the ci database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:11:51Z You are using PostgreSQL 16.11 for the main database, but this version of GitLab requires PostgreSQL >= 17. 2026-07-09T11:11:51Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:11:51Z https://docs.gitlab.com/ee/install/requirements.html#database for details. 2026-07-09T11:11:51Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:11:51Z βββ βββ ββββββ βββββββ ββββ ββββββββββ βββ ββββββ 2026-07-09T11:11:51Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:11:51Z βββ ββββββββββββββββββββββββ βββββββββββ βββββ 2026-07-09T11:11:51Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:11:51Z βββ ββ βββββββββββββββββββββββββ ββββββββββββ ββββββ βββ 2026-07-09T11:11:51Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:11:51Z ββββββββββββββββββββββββββββββββββββββββββββββββββββ ββ 2026-07-09T11:11:51Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ 2026-07-09T11:11:51Z ββββββββββββ ββββββ ββββββ ββββββββββββ βββββββββββββ -
Install Additional Python Module for OpenWebUIInstallation of additional packages would be great! Would a quick fix be to make the directory "/app/code/venv/lib/python3.12/site-packages/" writable in the cloudron app (eg. symlink to a /app/data/site-packages directory)?
-
EntraID / AzureAD LDAP wrapper@JLX89 said in EntraID / AzureAD LDAP wrapper:
How about just using an Enterprise App with SCIM Provisioning?
That would be great

-
Potential dataloss in Memos with Cloudron 8.3.0 upgrade?Oh yeah, I had an issue with Nextcloud as well after the upgrade. Forgot to mention that. Same thing, some table (I think it was oc_appinfo) could not be found. A restore of the backup right before the upgrade fixed that for me as well.
Same for Cal, Outline, Documenso, Linkwarden and Formbricks by the way. The app started but with a fresh database. A restore brought all back.
I am very happy with the great backup/restore concept and automated backups before an upgrade. Works so great. -
Potential dataloss in Memos with Cloudron 8.3.0 upgrade?Great! Must have been something on my server then - all good, I was able to restore from a previous backup and it was just test data anyways... Thanks for checking!
-
Potential dataloss in Memos with Cloudron 8.3.0 upgrade?I configured access to the old backups and restored one before the upgrade to 8.3.0. All data is back now! Not sure what happened, but if it doesn't occur in your CI testing it might just have been something strange on my system.
-
Potential dataloss in Memos with Cloudron 8.3.0 upgrade? -
Potential dataloss in Memos with Cloudron 8.3.0 upgrade?Just a quick observation: after upgrading from Cloudron 8.2.x to 8.3.0, all data in Memos for my OIDC user has vanished. No problem for me as I was just starting to use it and only had some test data in Memos. Could this be related to the database upgrade of postgresql? Unfortunately, I cannot assist in debugging as I migrated Cloudron to a beefier server (always amazing how simple and elegant that ist!) in the meantime and do not have easy access to the old logs / backups / etc.
-
Tika ServerIt would be awesome if openwebui could use the Cloudron Tika server.
-
Weird email log probably spam attack?You can also follow this great guide and set up an automated blocklist update:
https://forum.cloudron.io/topic/3795/firewall-spamassassin-automatic-list-update/41?_=1740739173375Might mitigate some (few) of these annoying spam attacks.