Cloudron makes it easy to run web apps like WordPress, Nextcloud, GitLab on your server. Find out more or install now.


Skip to content

LAMP

119 Topics 777 Posts
  • Setting the Correct File Owner

    Solved
    10
    1 Votes
    10 Posts
    487 Views
    micmcM

    @girish Useful info mate! 🙂

  • Redirect document root to a subfolder?

    Solved
    3
    0 Votes
    3 Posts
    189 Views
    micmcM

    Good work 😉 @humptydumpty

  • SphinxSearch

    1
    0 Votes
    1 Posts
    133 Views
    No one has replied
  • what if I need 2 databases ?

    Solved
    3
    1 Votes
    3 Posts
    225 Views
    nebulonN

    @jodumont said in what if I need 2 databases ?:

    BTW: I found a typo: CLUODRON_MYSQL_DATABASE_PREFIX

    thanks for reporting! I've fixed it now in the docs.

  • LAMP PHP Set to 8.0. Doesn't update

    Moved
    7
    0 Votes
    7 Posts
    432 Views
    girishG

    @ghodgeon said in LAMP PHP Set to 8.0. Doesn't update:

    COMPOSER_MEMORY_LIMIT=-1 composer create-project pimcore/demo my-project

    Can you try:

    COMPOSER_MEMORY_LIMIT=-1 php8.0 /usr/bin/composer create-project pimcore/demo my-project
  • apache not allow authorization header ?

    5
    0 Votes
    5 Posts
    1k Views
    girishG

    @freetommy mm, I assumed what you tried didn't work. It works for me.

    I put the below in /app/data/.htaccess (placing this in /app/data/apache/app.conf inside VirtualHost also works:

    SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

    Restart the app. Then, I see the header passed on to PHP:

    [HTTP_AUTHORIZATION] => Bearer YWxhZGRpbjpvcGVuc2VzYW1l

    For future reference, this also worked (in apache config):

    RewriteEngine On RewriteCond %{HTTP:Authorization} ^(.*) RewriteRule .* - [e=HTTP_AUTHORIZATION:%1]
  • Disable phpMyAdmin

    Solved
    5
    1 Votes
    5 Posts
    355 Views
    J

    @girish Thank you!

  • 0 Votes
    9 Posts
    549 Views
    scookeS

    @shai Glad to hear it, I was going to give it a try this weekend, so this saves me a bit of time. Congrats.

  • installing Drupal 9 fails

    Solved
    7
    0 Votes
    7 Posts
    343 Views
    L

    @shai

    What is the latest on deploying Drupal using Cloudron everybody?

  • SQL modes

    5
    0 Votes
    5 Posts
    328 Views
    C

    @nebulon I also think plain database apps would be the way to go here. Patching the app code is complicated in this particular case, so for now I I will just go with an external database.

  • 0 Votes
    3 Posts
    275 Views
    nebulonN

    @jagan thanks for sharing the solution!

  • Mysql "loading local data disabled" error

    Solved
    3
    0 Votes
    3 Posts
    356 Views
    ShaiS

    @girish the local_infile is the approach the app uses to load data sets for optional functionality. I'll go to the forum for OpenEMR and see if there is a way for me to manually upload the data instead of being done through the webapp UI.

  • 0 Votes
    4 Posts
    340 Views
    ShaiS

    @girish Thank you!

  • Lamp mail don't work

    Moved
    6
    0 Votes
    6 Posts
    252 Views
    girishG

    I was able to send mails with PHPMailer.

    <?php use PHPMailer\PHPMailer\PHPMailer; use PHPMailer\PHPMailer\Exception; require 'vendor/autoload.php'; $sender = getenv('CLOUDRON_MAIL_FROM'); $senderName = 'LAMP Test Email'; $recipient = 'test@cloudron.io'; $usernameSmtp = getenv('CLOUDRON_MAIL_SMTP_USERNAME'); $passwordSmtp = getenv('CLOUDRON_MAIL_SMTP_PASSWORD'); $host = getenv('CLOUDRON_MAIL_SMTP_SERVER'); $port = (int) getenv('CLOUDRON_MAIL_SMTP_PORT'); $subject = 'Cloudron test (SMTP interface accessed using PHP)'; $bodyText = "Email Test\r\nThis email was sent through the Cloudron SMTP interface using the PHPMailer class."; $bodyHtml = '<h1>Email Test</h1>'; $mail = new PHPMailer(true); try { $mail->isSMTP(); $mail->setFrom($sender, $senderName); $mail->Username = $usernameSmtp; $mail->Password = $passwordSmtp; $mail->Host = $host; $mail->Port = $port; $mail->SMTPAuth = true; $mail->addAddress($recipient); $mail->isHTML(true); $mail->Subject = $subject; $mail->Body = $bodyHtml; $mail->AltBody = $bodyText; $mail->Send(); echo "Email sent!" , PHP_EOL; } catch (phpmailerException $e) { echo "An error occurred. {$e->errorMessage()}", PHP_EOL; //Catch errors from PHPMailer. } catch (Exception $e) { echo "Email not sent. {$mail->ErrorInfo}", PHP_EOL; } ?>

    (Adapted from https://docs.aws.amazon.com/ses/latest/DeveloperGuide/send-using-smtp-php.html )

  • LAMP composer: command not found

    Moved
    8
    0 Votes
    8 Posts
    398 Views
    girishG

    @thenils I have pushed a new package, can you please check? It should have composer 2.1.8

  • Update to PHP8

    9
    0 Votes
    9 Posts
    616 Views
    girishG

    @argovaerts @darkben The latest package supports PHP 8. See https://docs.cloudron.io/apps/lamp/#supported-php-versions on how to switch.

  • No php error

    Moved
    2
    0 Votes
    2 Posts
    216 Views
    nebulonN

    @softdoctor hi there, not sure how this is related to Cloudron. On Cloudron apps are installed in their own containers, did you try to use the lamp app for this?

  • 0 Votes
    4 Posts
    282 Views
    D

    @girish Thanks!

  • Verify Cron is Running

    Solved
    9
    0 Votes
    9 Posts
    626 Views
    J

    @girish said in Verify Cron is Running:

    1 * * * * (echo "Trigger is running now"; /usr/bin/php -d memory_limit=-1 -d max_execution_time=0 /app/data/public/path/to/task/trigger.php) > /proc/$(cat /var/run/crond.pid)/fd/1 2>&1

    Perfect, thank you so much! That worked out very well!

  • opcache.enable

    Solved
    6
    0 Votes
    6 Posts
    358 Views
    C

    @girish Embarassingly it appears ther script that I was loading the php info through had specifically set opcache.enable to Off at runtime. In the app itself it is enables and all is good. Thanks again and apologies for the unnecessary effort in pushing a new package.